summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorjoey <joey>2000-03-02 21:23:22 +0000
committerjoey <joey>2000-03-02 21:23:22 +0000
commit67b74298f08a3e2b30e43cbcd7cdaccc2e1b1614 (patch)
tree3ce180eedb8c91f9371456f3fb40336b4c7c34dd /doc
parentc7f541bd2bc869c366e8242baf1faa6856cd2e39 (diff)
r338: * Patch from Jorgen `forcer' Schaefer <forcer at mindless.com> (much
modified)to make dh_installwm use new window manager registration method, update-alternatives. Closes: #52156, #34684 (latter bug is obsolete) * Fixed $dh{flavor} to be upper-case. * Deprecated dh_installemavcsen --number; use --priority instead. Also, the option parser requires the parameter be a number now. And, dh_installwm now accepts --priority, and window manager packages should start using it. * dh_installwm now behaves like a proper debhelper command, and reads debian/<package>.wm too. This is a small behavior change; filenames specified on the command line no longer apply to all packages it acts on. I can't belive this program existed for 2 years with such a glaring problem; I guess most people don't need ot register 5 wm's in 3 sub-packages. Anyway, it can handle such things now. :-) * Moved Dh_*.pm to /usr/lib/perl5/Debian/Debhelper. *big* change.
Diffstat (limited to 'doc')
-rw-r--r--doc/PROGRAMMING23
-rw-r--r--doc/README2
-rw-r--r--doc/TODO3
-rw-r--r--doc/v21
4 files changed, 17 insertions, 12 deletions
diff --git a/doc/PROGRAMMING b/doc/PROGRAMMING
index f4d14bd0..df9a7287 100644
--- a/doc/PROGRAMMING
+++ b/doc/PROGRAMMING
@@ -16,9 +16,9 @@ passed -v, and if you output the commands, you should indent them with 1 tab).
This is so we don't have a lot of noise output when all the debhelper commands
in a debian/rules are run, so the important stuff is clearly visible.
-Debhelper programs should accept the options, -v, -i, -a, -p, --no-act, and
--P, and any long forms of these options, like --verbose . If necessary, the
-options may be ignored.
+Debhelper programs should accept all options listed in the "SHARED
+DEBHELPER OPTIONS" section of debhelper(1), including and any long forms of
+these options, like --verbose . If necessary, the options may be ignored.
If debhelper commands need config files, they should use
debian/package.filename as the name of the config file (replace filename
@@ -41,9 +41,9 @@ There are always exceptions. Just ask me.
Introducing Dh_Lib.pm:
---------------------
-Dh_lib.pm is the library used by all debhelper programs to parse their
+Dh_Lib.pm is the library used by all debhelper programs to parse their
arguments and set some useful variables. It's not mandatory that your
-program use Dh_lib.pm, but it will make it a lot easier to keep it in sync
+program use Dh_Lib.pm, but it will make it a lot easier to keep it in sync
with the rest of debhelper if it does, so this is highly encouraged.
(There used to be a version of Dh_lib.pm that was a library of functions for
@@ -51,17 +51,16 @@ shell scripts. If you want to write a debhelper command that is a shell
script, I can dig up that old library for you. Only the perl one is
supported now, though.)
-Use Dh_lib.pm like this:
+Use Dh_Lib.pm like this:
-BEGIN { push @INC, "debian", "/usr/share/debhelper" }
-use Dh_Lib;
+use Debian::Debhelper::Dh_Lib
init();
The BEGIN block is there to make perl look for the module in all the right
places.
-The init() function in the perl version. This causes Dh_lib to
-parse the command line and do some other initialization tasks.
+The init() function causes Dh_lib to parse the command line and do some other
+initialization tasks.
Argument processing:
-------------------
@@ -126,7 +125,8 @@ switch variable description
dh_builddeb will ever use this)
--flavor FLAVOR will be set to a string (probably only
dh_installemacsen will ever use this)
---number NUMBER will be set to a number
+--number PRIORITY will be set to a number (deprecated)
+--priority PRIORITY will be set to a number
Any additional command line parameters that do not start with "-" will be
ignored, and you can access them later just as you normally would.
@@ -206,3 +206,4 @@ autoscript()
maintainer script (like the postinst or prerm).
-- Joey Hess <joeyh@debian.org>
+
diff --git a/doc/README b/doc/README
index dcc42e61..93351579 100644
--- a/doc/README
+++ b/doc/README
@@ -20,7 +20,6 @@ Debhelper v2 is a major new version of Debhelper, still under development.
Debhelper will continue to work in v1 compatability mode for now, if you're
interested in trying the new versiln, read the file named "v2".
-
Starting a new package:
----------------------
@@ -72,3 +71,4 @@ Other notes:
* Debhelper's home page is at http://kitenet.net/programs/debhelper/
-- Joey Hess <joeyh@debian.org>
+
diff --git a/doc/TODO b/doc/TODO
index 54c95f3b..c341e96c 100644
--- a/doc/TODO
+++ b/doc/TODO
@@ -57,3 +57,6 @@ Deprecated:
one year after they were deprecated, whichever comes first. Be sure to
grep whole debian archive for all of them before removing them, though!
- currently, a few packages in potato use dh_du, but bugs have been filed.
+* Remove support for --number option
+ - only dh_installemacsen ever used it, it is not --priority.
+
diff --git a/doc/v2 b/doc/v2
index fdfa548d..327e625e 100644
--- a/doc/v2
+++ b/doc/v2
@@ -65,3 +65,4 @@ them.
* dh_makeshlibs will generate autoscript fragments for ldconfig. This will
require you call it before dh_installdeb, which isn't always done now.
+