summaryrefslogtreecommitdiff
path: root/t
diff options
context:
space:
mode:
authorSven Joachim <svenjoac@gmx.de>2017-07-03 15:02:29 +0000
committerNiels Thykier <niels@thykier.net>2017-07-03 15:08:13 +0000
commit35c18c7e9421ea8c459851d6146755af8fe74518 (patch)
treeb1f1e5f747cc72a051c31eaa68f3b303e89065c4 /t
parent1b2f59ad1a9d9748d6e30e16ce41251ffcaadc50 (diff)
Set Emacs file variables directory-wide
Set the local variables for Emacs in the central placed intended for it, rather than in (currently) 95 individual files. Signed-off-by: Niels Thykier <niels@thykier.net>
Diffstat (limited to 't')
-rwxr-xr-xt/buildsystems/01-build-system-basic-api.t6
-rwxr-xr-xt/buildsystems/02-make-jobserver-makeflags.t6
-rwxr-xr-xt/buildsystems/03-bs-auto-buildable.t5
-rwxr-xr-xt/buildsystems/04-dh_auto_do_autoconf.t5
-rwxr-xr-xt/buildsystems/05-load-build-system.t5
-rwxr-xr-xt/buildsystems/06-buildsystem-mkdir-rmdir.t5
-rwxr-xr-xt/buildsystems/load-bs.pl5
-rwxr-xr-xt/dh-lib.t5
-rwxr-xr-xt/dh_install/01-basics.t5
-rwxr-xr-xt/dh_install/03-866570-dont-install-from-host.t5
-rwxr-xr-xt/dh_installdocs/dh_installdocs.t5
-rwxr-xr-xt/dh_installinit/dh_installinit.t5
-rwxr-xr-xt/dh_link/01-basic.t5
-rwxr-xr-xt/dh_link/02-346405.t5
-rwxr-xr-xt/dh_missing/01-no-missing.t5
-rwxr-xr-xt/dh_missing/02-fail-on-missing.t5
-rwxr-xr-xt/dh_missing/03-dh_install-redirection.t5
-rwxr-xr-xt/maintscript.t5
-rwxr-xr-xt/override_target.t6
-rwxr-xr-xt/pod.t6
-rwxr-xr-xt/size.t6
-rwxr-xr-xt/syntax/syntax-progs.t5
22 files changed, 0 insertions, 115 deletions
diff --git a/t/buildsystems/01-build-system-basic-api.t b/t/buildsystems/01-build-system-basic-api.t
index 02a6cc65..dfb26d22 100755
--- a/t/buildsystems/01-build-system-basic-api.t
+++ b/t/buildsystems/01-build-system-basic-api.t
@@ -41,9 +41,3 @@ sub build_system_path_apis {
"/tmp/relative/path", "_rel2rel abs no7");
}
-
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/buildsystems/02-make-jobserver-makeflags.t b/t/buildsystems/02-make-jobserver-makeflags.t
index 56514529..9469759e 100755
--- a/t/buildsystems/02-make-jobserver-makeflags.t
+++ b/t/buildsystems/02-make-jobserver-makeflags.t
@@ -55,9 +55,3 @@ sub test_clean_jobserver_makeflags {
is($ENV{MAKEFLAGS}, $expected, $test);
}
-
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/buildsystems/03-bs-auto-buildable.t b/t/buildsystems/03-bs-auto-buildable.t
index 83884c18..77845ced 100755
--- a/t/buildsystems/03-bs-auto-buildable.t
+++ b/t/buildsystems/03-bs-auto-buildable.t
@@ -214,8 +214,3 @@ sub run_autoselection_tests {
};
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/buildsystems/04-dh_auto_do_autoconf.t b/t/buildsystems/04-dh_auto_do_autoconf.t
index e3bbceeb..a1346e42 100755
--- a/t/buildsystems/04-dh_auto_do_autoconf.t
+++ b/t/buildsystems/04-dh_auto_do_autoconf.t
@@ -86,8 +86,3 @@ dh_auto_do_autoconf('autoconf');
dh_auto_do_autoconf('autoconf', 'bld/dir', configure_args => [ "--extra-autoconf-configure-arg" ]);
ok ( ! -e 'bld', "bld got deleted too" );
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/buildsystems/05-load-build-system.t b/t/buildsystems/05-load-build-system.t
index 0004176b..447241b6 100755
--- a/t/buildsystems/05-load-build-system.t
+++ b/t/buildsystems/05-load-build-system.t
@@ -53,8 +53,3 @@ sub try_load_bs {
return \@lines;
}
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/buildsystems/06-buildsystem-mkdir-rmdir.t b/t/buildsystems/06-buildsystem-mkdir-rmdir.t
index 8dc36f75..c13b2536 100755
--- a/t/buildsystems/06-buildsystem-mkdir-rmdir.t
+++ b/t/buildsystems/06-buildsystem-mkdir-rmdir.t
@@ -49,8 +49,3 @@ sub do_rmdir_builddir {
$system->rmdir_builddir();
}
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/buildsystems/load-bs.pl b/t/buildsystems/load-bs.pl
index d8f56c2a..aeb5ea80 100755
--- a/t/buildsystems/load-bs.pl
+++ b/t/buildsystems/load-bs.pl
@@ -14,8 +14,3 @@ if (defined $bs) {
foreach (sort keys %$bs);
}
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/dh-lib.t b/t/dh-lib.t
index 0101f030..d1eb355a 100755
--- a/t/dh-lib.t
+++ b/t/dh-lib.t
@@ -37,8 +37,3 @@ each_compat_subtest {
ok(rm_files('debian/testpackage.postinst.debhelper'));
}
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/dh_install/01-basics.t b/t/dh_install/01-basics.t
index 863c92c9..b266196f 100755
--- a/t/dh_install/01-basics.t
+++ b/t/dh_install/01-basics.t
@@ -31,8 +31,3 @@ each_compat_subtest {
remove_tree('debian/debhelper', 'debian/tmp');
};
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/dh_install/03-866570-dont-install-from-host.t b/t/dh_install/03-866570-dont-install-from-host.t
index 33834d9b..92345d1d 100755
--- a/t/dh_install/03-866570-dont-install-from-host.t
+++ b/t/dh_install/03-866570-dont-install-from-host.t
@@ -22,8 +22,3 @@ each_compat_subtest {
remove_tree('debian/debhelper', 'debian/tmp');
};
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/dh_installdocs/dh_installdocs.t b/t/dh_installdocs/dh_installdocs.t
index 34d5a3b4..86746cfc 100755
--- a/t/dh_installdocs/dh_installdocs.t
+++ b/t/dh_installdocs/dh_installdocs.t
@@ -78,8 +78,3 @@ each_compat_subtest {
remove_tree(qw(debian/foo debian/bar debian/baz));
};
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/dh_installinit/dh_installinit.t b/t/dh_installinit/dh_installinit.t
index 098107cd..20860f19 100755
--- a/t/dh_installinit/dh_installinit.t
+++ b/t/dh_installinit/dh_installinit.t
@@ -44,8 +44,3 @@ each_compat_from_and_above_subtest(11, sub {
ok(run_dh_tool('dh_clean'));
});
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/dh_link/01-basic.t b/t/dh_link/01-basic.t
index 220ea19d..88c8e49c 100755
--- a/t/dh_link/01-basic.t
+++ b/t/dh_link/01-basic.t
@@ -48,8 +48,3 @@ each_compat_subtest {
ok(readlink("debian/debhelper/usr/bin/2"),"../lib/1");
};
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/dh_link/02-346405.t b/t/dh_link/02-346405.t
index ce64ddd9..95053ca8 100755
--- a/t/dh_link/02-346405.t
+++ b/t/dh_link/02-346405.t
@@ -27,8 +27,3 @@ each_compat_subtest {
ok(readlink("debian/debhelper/usr/lib/geant4/d"), "/");
};
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/dh_missing/01-no-missing.t b/t/dh_missing/01-no-missing.t
index 2528d2d5..e3cd3116 100755
--- a/t/dh_missing/01-no-missing.t
+++ b/t/dh_missing/01-no-missing.t
@@ -26,8 +26,3 @@ each_compat_subtest {
ok(run_dh_tool('dh_missing', '--fail-missing'), 'dh_missing failed');
};
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/dh_missing/02-fail-on-missing.t b/t/dh_missing/02-fail-on-missing.t
index fa1a6869..711ed984 100755
--- a/t/dh_missing/02-fail-on-missing.t
+++ b/t/dh_missing/02-fail-on-missing.t
@@ -31,8 +31,3 @@ each_compat_subtest {
is($exitcode, 2, 'dh_missing exited with exit code 2');
};
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/dh_missing/03-dh_install-redirection.t b/t/dh_missing/03-dh_install-redirection.t
index ce56fec1..2235b086 100755
--- a/t/dh_missing/03-dh_install-redirection.t
+++ b/t/dh_missing/03-dh_install-redirection.t
@@ -28,8 +28,3 @@ each_compat_up_to_and_incl_subtest(10, sub {
'-X', 'more', '--exclude', 'lots', '--fail-missing'));
});
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/maintscript.t b/t/maintscript.t
index 8e421585..a69c99c7 100755
--- a/t/maintscript.t
+++ b/t/maintscript.t
@@ -38,8 +38,3 @@ EOF
}
});
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/override_target.t b/t/override_target.t
index 2e4a4548..b56c9862 100755
--- a/t/override_target.t
+++ b/t/override_target.t
@@ -23,9 +23,3 @@ system("chmod +x t/tmp/debian/rules");
my @output=`cd t/tmp && debian/rules build 2>&1`;
ok(grep { m/override called/ } @output);
system("rm -rf t/tmp");
-
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/pod.t b/t/pod.t
index b5b5694e..8a9c0bf0 100755
--- a/t/pod.t
+++ b/t/pod.t
@@ -8,9 +8,3 @@ eval 'use Test::Pod';
plan skip_all => 'Test::Pod required' if $@;
all_pod_files_ok(grep { -x $_ } glob 'dh_*');
-
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/size.t b/t/size.t
index 94d45dfd..79564af8 100755
--- a/t/size.t
+++ b/t/size.t
@@ -29,9 +29,3 @@ foreach my $file (@progs) {
ok($lines < 200, $file);
ok($maxlength < 160, $file);
}
-
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End:
diff --git a/t/syntax/syntax-progs.t b/t/syntax/syntax-progs.t
index 37ece051..0dbdb2a2 100755
--- a/t/syntax/syntax-progs.t
+++ b/t/syntax/syntax-progs.t
@@ -22,8 +22,3 @@ foreach my $file (@targets) {
or diag("$file failed syntax check");
}
-# Local Variables:
-# indent-tabs-mode: t
-# tab-width: 4
-# cperl-indent-level: 4
-# End: