summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installxfonts2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 054f4ddb..e16b8a30 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (7.0.7) unstable; urgency=low
+
+ * dh_installxfonts: Fix precidence problem that exposes a new warning
+ message in perl 5.10.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 04 May 2008 13:43:41 -0400
+
debhelper (7.0.6) unstable; urgency=low
* dh_auto_test: Correct Module::Build tests.
diff --git a/dh_installxfonts b/dh_installxfonts
index b7921a2b..276f903c 100755
--- a/dh_installxfonts
+++ b/dh_installxfonts
@@ -52,7 +52,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Find all font directories in the package build directory.
my @fontdirs;
foreach my $parentdir ("$tmp/usr/X11R6/lib/X11/fonts/", "$tmp/usr/share/fonts/X11/") {
- opendir DIR, $parentdir || next;
+ opendir(DIR, $parentdir) || next;
@fontdirs = grep { -d "$parentdir/$_" && !/^\./ } (readdir DIR);
closedir DIR;
}