summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autoscripts/postrm-wm2
-rw-r--r--autoscripts/prerm-wm3
-rw-r--r--autoscripts/prerm-xaw9
-rw-r--r--debian/changelog8
4 files changed, 16 insertions, 6 deletions
diff --git a/autoscripts/postrm-wm b/autoscripts/postrm-wm
deleted file mode 100644
index c4670b9f..00000000
--- a/autoscripts/postrm-wm
+++ /dev/null
@@ -1,2 +0,0 @@
-update-alternatives --remove x-window-manager #WM#
-
diff --git a/autoscripts/prerm-wm b/autoscripts/prerm-wm
new file mode 100644
index 00000000..b97d627f
--- /dev/null
+++ b/autoscripts/prerm-wm
@@ -0,0 +1,3 @@
+if [ "$1" = "remove" ]; then
+ update-alternatives --remove x-window-manager #WM#
+fi
diff --git a/autoscripts/prerm-xaw b/autoscripts/prerm-xaw
index 2507a2f5..98837f82 100644
--- a/autoscripts/prerm-xaw
+++ b/autoscripts/prerm-xaw
@@ -1,4 +1,5 @@
-for opts in #OPTS#; do
- update-alternatives --quiet --remove $opts
-done
-
+if [ "$1" = "remove" ]; then
+ for opts in #OPTS#; do
+ update-alternatives --quiet --remove $opts
+ done
+fi
diff --git a/debian/changelog b/debian/changelog
index d6bacad1..bab54222 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (2.2.8) unstable; urgency=medium
+
+ * dh_installwm: Moved update-alternatives --remove call to prerm,
+ Closes: #80209
+ * ALso guarded all update-alternatives --remove calls.
+
+ -- Joey Hess <joeyh@debian.org> Thu, 21 Dec 2000 11:33:30 -0800
+
debhelper (2.2.7) unstable; urgency=low
* Spelling patch.