summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installdeb3
2 files changed, 9 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 0db61b2b..4c1992eb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (5.0.59) unstable; urgency=low
+
+ * dh_installdeb: Add support for dpkg triggers, by installing
+ debian/package.triggers files.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 22 Oct 2007 13:58:36 -0400
+
debhelper (5.0.58) unstable; urgency=low
* dh_clean: append "/" to the temp dir name to avoid removing
diff --git a/dh_installdeb b/dh_installdeb
index a3cd68ff..fdc76e60 100755
--- a/dh_installdeb
+++ b/dh_installdeb
@@ -27,6 +27,7 @@ the DEBIAN directory:
package.prerm
package.shlibs
package.conffiles
+ package.triggers
The postinst, preinst, postrm, and prerm are handled specially: If a
corresponding file named debian/package.script.debhelper exists, the contents
@@ -68,7 +69,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (! is_udeb($package)) {
# Install non-executable files
- foreach my $file (qw{shlibs conffiles}) {
+ foreach my $file (qw{shlibs conffiles triggers}) {
my $f=pkgfile($package,$file);
if ($f) {
doit("install","-o",0,"-g",0,"-m",644,"-p",$f,"$tmp/DEBIAN/$file");