summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm13
-rw-r--r--debian/changelog4
2 files changed, 13 insertions, 4 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index c29a9529..9274a7d1 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -83,6 +83,12 @@ sub dbg_build_needed {
my $this=shift;
my $act=shift;
+ # Return a list of python-dbg package which are listed
+ # in the build-dependencies. This is kinda ugly, but building
+ # dbg extensions without checking if they're supposed to be
+ # built may result in various FTBFS if the package is not
+ # built in a clean chroot.
+
my @dbg;
open (CONTROL, $this->get_sourcepath('debian/control')) ||
error("cannot read debian/control: $!\n");
@@ -116,7 +122,7 @@ sub setup_py {
my @python_requested = split ' ', `pyversions -r 2>/dev/null`;
if (grep /^$python_default/, @python_requested) {
@python_requested = ("python", grep(!/^$python_default/,
- @python_requested);
+ @python_requested));
}
my @dbg_build_needed = $this->dbg_build_needed();
@@ -125,10 +131,11 @@ sub setup_py {
$this->doit_in_sourcedir($python, "setup.py", $act, @_);
}
$python = $python . "-dbg";
- if (grep /^(python-all-dbg|$python)/, @dbg_build_needed) {
+ if ((grep /^(python-all-dbg|$python)/, @dbg_build_needed)
+ or (($python eq "python-dbg")
+ and (grep /^$python_default/, @dbg_build_needed))){
$this->doit_in_sourcedir($python, "setup.py", $act, @_);
}
-
}
}
diff --git a/debian/changelog b/debian/changelog
index 8e70d28f..dd75a83f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,8 +4,10 @@ debhelper (7.3.5) experimental; urgency=low
versions in case they're installed. Ensure that correct
shebangs are created by using `python' first during build
and install. Closes: #520834
+ Also build with python*-dbg in case the package build-depends
+ on them.
- -- Bernd Zeimetz <bzed@debian.org> Sun, 19 Jul 2009 03:45:23 +0200
+ -- Bernd Zeimetz <bzed@debian.org> Sun, 19 Jul 2009 15:26:13 +0200
debhelper (7.3.4) experimental; urgency=low