summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_installman5
2 files changed, 7 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 0ba88a8e..2c144046 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,8 @@ debhelper (5.0.27) UNRELEASED; urgency=low
[ Joey Hess ]
* Typo. Closes: #358904
* dh_install: swap two paras in man page for clarity. Closes: #359182
+ * dh_installman: die with an error if a man page read for so lines fails
+ Closes: #359020
[ Valery Perrin ]
* Update pot file and french translation with recent changes in
diff --git a/dh_installman b/dh_installman
index 6544eae4..e8ed27da 100755
--- a/dh_installman
+++ b/dh_installman
@@ -205,6 +205,11 @@ sub find_so_man {
}
my $l=<SOTEST>;
close SOTEST;
+
+ if (! defined $l) {
+ error("failed to read $_");
+ }
+
if ($l=~m/\.so\s+(.*)\s*/) {
my $solink=$1;
# This test is here to prevent links like ... man8/../man8/foo.8