summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installchangelogs2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 2f107939..ebcb3818 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (7.0.18) UNRELEASED; urgency=low
+
+ * dh_installchangelogs: Fall back to looking for changelog files ending
+ with ".txt". Closes: #498460
+
+ -- Joey Hess <joeyh@debian.org> Wed, 10 Sep 2008 13:58:00 -0400
+
debhelper (7.0.17) unstable; urgency=low
[ Per Olofsson ]
diff --git a/dh_installchangelogs b/dh_installchangelogs
index 7042c5f9..a5cce3f4 100755
--- a/dh_installchangelogs
+++ b/dh_installchangelogs
@@ -68,7 +68,7 @@ my $changelog_name="changelog.Debian";
if (! defined $upstream) {
if (! isnative($dh{MAINPACKAGE}) && !compat(6)) {
my @files=sort glob("*");
- foreach my $name (qw{changelog changes}) {
+ foreach my $name (qw{changelog changes changelog.txt changes.txt}) {
my @matches=grep { lc $_ eq $name && -s $_ } @files;
if (@matches) {
$upstream=shift @matches;