summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdh7
2 files changed, 6 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index d27c286b..60c84c29 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,7 @@ debhelper (9.20120115) unstable; urgency=low
* It is now deprecated for a package to not specify a compatibility
level in debian/compat. Debhelper now warns if this is not done,
and packages without a debian/compat will eventually FTBFS.
+ * dh: --without foo,bar now supported.
* Updated German man page translation. Closes: #653360
-- Joey Hess <joeyh@debian.org> Sun, 15 Jan 2012 13:59:49 -0400
diff --git a/dh b/dh
index 36130f84..4d4e31eb 100755
--- a/dh
+++ b/dh
@@ -55,7 +55,9 @@ the sequence addon interface.
=item B<--without> I<addon>
-The inverse of B<--with>, disables using the given addon.
+The inverse of B<--with>, disables using the given addon. This option
+can be repeated more than once, or multiple addons to disable can be
+listed, separated by commas.
=item B<--list>, B<-l>
@@ -285,7 +287,8 @@ init(options => {
},
"without=s" => sub {
my ($option,$value)=@_;
- @{$dh{WITH}} = grep { $_ ne $value } @{$dh{WITH}};
+ my %without = map { $_ => 1 } split(",", $value);
+ @{$dh{WITH}} = grep { ! $without{$_} } @{$dh{WITH}};
},
"l" => \&list_addons,
"list" => \&list_addons,