summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_makeshlibs6
2 files changed, 2 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 40ce528b..8c3cdbdd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -19,8 +19,6 @@ debhelper (7.4.8) unstable; urgency=low
be enabled by using the --max-parallel option. This was necessary because
some buildds build with -j2 by default. (See #532805)
* dh: Document --no-act. Closes: #557505
- * dh_makeshlibs: Make -X also exclude libraries from the symbols file.
- Closes: #557603 (Peter Samuelson)
-- Joey Hess <joeyh@debian.org> Mon, 23 Nov 2009 13:57:10 -0500
diff --git a/dh_makeshlibs b/dh_makeshlibs
index 4e4a8e21..03a54f95 100755
--- a/dh_makeshlibs
+++ b/dh_makeshlibs
@@ -139,14 +139,13 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# because only if we can get a library name and a major number from
# objdump is anything actually added.
my $exclude='';
- my (@udeb_lines, @lib_files);
+ my @udeb_lines;
if (defined($dh{EXCLUDE_FIND}) && $dh{EXCLUDE_FIND} ne '') {
$exclude="! \\( $dh{EXCLUDE_FIND} \\) ";
}
open (FIND, "find $tmp -type f \\( -name '*.so' -or -name '*.so.*' \\) $exclude |");
while (<FIND>) {
my ($library, $major);
- push @lib_files, $_;
my $objdump=`objdump -p $_`;
if ($objdump=~m/\s+SONAME\s+(.+)\.so\.(.+)/) {
# proper soname format
@@ -228,8 +227,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# is not 100% compatible with debhelper. (For example,
# this supports --ignore being used.)
doit("dpkg-gensymbols", "-p$package", "-I$symbols",
- "-P$tmp", (map { "-e$_" } @lib_files),
- @{$dh{U_PARAMS}});
+ "-P$tmp", @{$dh{U_PARAMS}});
if (-s "$tmp/DEBIAN/symbols" == 0) {
doit("rm", "-f", "$tmp/DEBIAN/symbols");
}