summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debhelper.pod10
-rw-r--r--debian/changelog9
-rwxr-xr-xdh_installdeb14
3 files changed, 22 insertions, 11 deletions
diff --git a/debhelper.pod b/debhelper.pod
index 70f14100..1428a3b1 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -1056,10 +1056,12 @@ Note the B<--> before the B<--libexecdir> parameter.
=item -
-The B<dh_installdeb> tool no longer installs the maintainer provided
-F<conffiles> file. The file has mostly been obsolete since
-compatibility level 3, where B<dh_installdeb> began to automatically
-compute the resulting F<conffiles> control file.
+B<Retroactively removed in debhelper/13.5>:
+
+The B<dh_installdeb> tool would no longer installs the maintainer provided
+F<conffiles> file as it was deemed unnecessary. However, the
+B<remove-on-upgrade> from dpkg/1.20 made the file relevant again and
+B<dh_installdeb> now installs it again in compat levels 12+.
=item -
diff --git a/debian/changelog b/debian/changelog
index e9682bf5..ddc4cbe6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+debhelper (13.5) UNRELEASED; urgency=medium
+
+ * dh_installdeb: Install debian/conffiles in compat 12+ again
+ (undoing the compat 12 change saying dh_installdeb would ignore
+ this file). The file can now be using for the activating the
+ `remove-on-upgrade` feature from dpkg 1.20.
+
+ -- Niels Thykier <niels@thykier.net> Sun, 22 Aug 2021 07:13:37 +0000
+
debhelper (13.4.1) unstable; urgency=medium
[ Clint Adams ]
diff --git a/dh_installdeb b/dh_installdeb
index 25ed4e82..d662b68c 100755
--- a/dh_installdeb
+++ b/dh_installdeb
@@ -56,13 +56,13 @@ earlier. In compat 10, please use L<dh_makeshlibs(1)>.
=item I<package>.conffiles
-Historically, this file was needed to manually mark files files as
-conffiles. However, it has become de facto obsolete since debhelper
-automatically computed which files should be marked as conffiles.
+This file will be installed into the F<DEBIAN> directory. The
+provided file will be enriched by debhelper to include all the
+B<conffiles> auto-detected by debhelper (the maintainer should
+not list there as debhelper assumes it should handle that part).
-In compatibility level up and including 11, this control file will be
-installed into the F<DEBIAN> directory. In compatibility level 12 and
-later, the file is silently ignored.
+This file is primarily useful for using "special" entries such as
+the B<< remove-on-upgrade >> feature from dpkg.
=item I<package>.maintscript
@@ -304,7 +304,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Install non-executable files
my @non_exec_files;
# Removed in compat 12.
- push(@non_exec_files, 'conffiles') if compat(11);
+ push(@non_exec_files, 'conffiles');
# In compat 10, we let dh_makeshlibs handle "shlibs".
push(@non_exec_files, 'shlibs') if compat(9);
foreach my $file (@non_exec_files) {