summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_strip2
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 868c699e..3eeae05a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (3.0.14) unstable; urgency=low
+
+ * dh_strip: ensure that the file _ends_ with `.a'. Closes: #90647
+
+ -- Joey Hess <joeyh@debian.org> Wed, 21 Mar 2001 20:21:11 -0800
+
debhelper (3.0.13) unstable; urgency=low
* dh_makeshlibs: more support for nasty soname formats, Closes: #90520
diff --git a/dh_strip b/dh_strip
index a0d69aec..cf36085d 100755
--- a/dh_strip
+++ b/dh_strip
@@ -89,7 +89,7 @@ sub testfile {
}
# Is it a static library, and not a debug library?
- if (m/lib.*\.a/ && ! m/.*_g\.a/) {
+ if (m/lib.*\.a$/ && ! m/.*_g\.a$/) {
push @static_libs, $fn;
return;
}