summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdh_installdocs3
2 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 34cb71fe..adb1b2f0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,9 @@ debhelper (7.3.16) UNRELEASED; urgency=low
* dh_desktop: Clarify in man page why it's a no-op.
Closes: #543364
+ * dh_installdocs: Loosen the Document field parsing, to accept
+ everything doc-base *really* accepts in a doc id (not just what
+ it's documented to accept). Closes: #543499
-- Joey Hess <joeyh@debian.org> Mon, 24 Aug 2009 12:59:02 -0400
diff --git a/dh_installdocs b/dh_installdocs
index 87954116..1226cf8f 100755
--- a/dh_installdocs
+++ b/dh_installdocs
@@ -200,7 +200,8 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Parse the file to get the doc id.
open (IN, "debian/$fn") || die "Cannot read debian/$fn.";
while (<IN>) {
- if (/^Document:\s+([-+.a-z0-9]+)/) {
+ s/\s*$//;
+ if (/^Document\s*:\s*(.*)/) {
$doc_ids{$fn}=$1;
last;
}