summaryrefslogtreecommitdiff
path: root/dh_gencontrol
diff options
context:
space:
mode:
Diffstat (limited to 'dh_gencontrol')
-rwxr-xr-xdh_gencontrol8
1 files changed, 2 insertions, 6 deletions
diff --git a/dh_gencontrol b/dh_gencontrol
index bde389de..887d35c2 100755
--- a/dh_gencontrol
+++ b/dh_gencontrol
@@ -67,9 +67,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
$changelog='debian/changelog';
}
- if ( ! -d "$tmp/DEBIAN" ) {
- install_dir("$tmp/DEBIAN");
- }
+ install_dir("$tmp/DEBIAN");
# avoid gratuitous warning
if (! -e $substvars || system("grep -q '^misc:Depends=' $substvars") != 0) {
@@ -124,9 +122,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
} else {
push(@dbgsym_options, '-UReplaces', '-UBreaks');
}
- if ( ! -d "${dbgsym_tmp}/DEBIAN" ) {
- install_dir("${dbgsym_tmp}/DEBIAN");
- }
+ install_dir("${dbgsym_tmp}/DEBIAN");
doit("dpkg-gencontrol", "-p${package}", "-l$changelog", "-T$substvars",
"-P${dbgsym_tmp}",@{$dh{U_PARAMS}}, @dbgsym_options);