summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAurélien COUDERC <zecoucou@free.fr>2018-05-21 14:08:35 +0200
committerAurélien COUDERC <zecoucou@free.fr>2018-05-21 14:08:35 +0200
commit346a6656e7dd1310fb9b99c88edf72f0aa15fec4 (patch)
treea5d31a5f70d862bf0cd1ec68453cb624abc17c10 /Makefile
parent1b269c495b456d83fd83b24ab525130138df20a9 (diff)
Tentative fix for intermittent build failure when doing parallel builds
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index ebf6ae0..d1dc82d 100644
--- a/Makefile
+++ b/Makefile
@@ -57,6 +57,7 @@ install-local:
### Plymouth theme
install -d $(DESTDIR)/usr/share/plymouth/themes/spacefun
$(INSTALL_DATA) $(wildcard spacefun-theme/plymouth/*) $(DESTDIR)/usr/share/plymouth/themes/spacefun
+ install -d $(DESTDIR)/usr/share/desktop-base/spacefun-theme
cd $(DESTDIR)/usr/share/desktop-base/spacefun-theme && ln -s /usr/share/plymouth/themes/spacefun plymouth
### Login background
install -d $(DESTDIR)/usr/share/desktop-base/spacefun-theme/login
@@ -80,6 +81,7 @@ install-local:
### Plymouth theme
install -d $(DESTDIR)/usr/share/plymouth/themes/joy
$(INSTALL_DATA) $(wildcard joy-theme/plymouth/*) $(DESTDIR)/usr/share/plymouth/themes/joy
+ install -d $(DESTDIR)/usr/share/desktop-base/joy-theme
cd $(DESTDIR)/usr/share/desktop-base/joy-theme && ln -s /usr/share/plymouth/themes/joy plymouth
### Login background
install -d $(DESTDIR)/usr/share/desktop-base/joy-theme/login
@@ -128,6 +130,7 @@ install-local:
### Plymouth theme
install -d $(DESTDIR)/usr/share/plymouth/themes/lines
$(INSTALL_DATA) $(wildcard lines-theme/plymouth/*) $(DESTDIR)/usr/share/plymouth/themes/lines
+ install -d $(DESTDIR)/usr/share/desktop-base/lines-theme
cd $(DESTDIR)/usr/share/desktop-base/lines-theme && ln -s /usr/share/plymouth/themes/lines plymouth
### Login background
install -d $(DESTDIR)/usr/share/desktop-base/lines-theme/login
@@ -157,6 +160,7 @@ install-local:
### Plymouth theme
install -d $(DESTDIR)/usr/share/plymouth/themes/softwaves
$(INSTALL_DATA) $(wildcard softwaves-theme/plymouth/*) $(DESTDIR)/usr/share/plymouth/themes/softwaves
+ install -d $(DESTDIR)/usr/share/desktop-base/softwaves-theme
cd $(DESTDIR)/usr/share/desktop-base/softwaves-theme && ln -s /usr/share/plymouth/themes/softwaves plymouth
### Login background
install -d $(DESTDIR)/usr/share/desktop-base/softwaves-theme/login