summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAurélien COUDERC <zecoucou@free.fr>2016-11-01 16:43:10 +0000
committerAurélien COUDERC <zecoucou@free.fr>2016-11-01 16:43:10 +0000
commit3df682bac7a0c47056ae6f91d297c424c4ee3e1f (patch)
tree94270abdf86df1155ef0a34068ac4e4104c9440e /Makefile
parent9bf87abed3ae48e1c027ca9aaa0f49e864f39a02 (diff)
Add Soft Waves support for GRUB
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index afc7d3a..7a4c258 100644
--- a/Makefile
+++ b/Makefile
@@ -1,15 +1,25 @@
+GRUB_THEMES=softwaves-theme/grub
DEFAULT_BACKGROUND=desktop-background
-INSTALL=install -m 0644
BACKGROUNDS=$(wildcard backgrounds/*.png backgrounds/*.jpg backgrounds/*.svg backgrounds/*.tga backgrounds/*.xml)
PIXMAPS=$(wildcard pixmaps/*.png)
DESKTOPFILES=$(wildcard *.desktop)
-all:
+all: build-grub
-clean:
+build-grub clean-grub install-grub:
+ @target=`echo $@ | sed s/-grub//`; \
+ for grub_theme in $(GRUB_THEMES) ; do \
+ if [ -f $$grub_theme/Makefile ] ; then \
+ $(MAKE) $$target -C $$grub_theme || exit 1; \
+ fi \
+ done$
-install:
+clean: clean-grub
+
+install: install-grub install-local
+
+install-local:
# background files
mkdir -p $(DESTDIR)/usr/share/images/desktop-base
$(INSTALL) $(BACKGROUNDS) $(DESTDIR)/usr/share/images/desktop-base
@@ -132,3 +142,5 @@ install:
# Lock screen symlink for KDE
install -d $(DESTDIR)/usr/share/wallpapers
cd $(DESTDIR)/usr/share/wallpapers && ln -s /usr/share/desktop-base/softwaves-theme/lockscreen SoftWavesLockScreen
+
+include Makefile.inc