summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJosselin Mouette <joss@debian.org>2012-06-23 21:28:19 +0000
committerJosselin Mouette <joss@debian.org>2012-06-23 21:28:19 +0000
commit7b433e6f058769f19eba3364295baec7ce14c83a (patch)
tree5a3cae30f11ad50f973a665b10352716a91a86e2 /Makefile
parentd20a9be24ff498da8d348113496515e1ffa47713 (diff)
* Remove GConf defaults, they are not used anymore.
* Remove the GDM3 settings, since the configuration format for GDM change again, yay. * Add a dconf file for the new-style GDM3 configuration. * Add a XML file describing the available resolutions for the background (for use with GNOME). * postinst: use a higher priority for the 1920x1080 background. * Cleanup postinst/prerm/postrm. * Add a new alternative: desktop-background.xml. * Use it from the gsettings override. * Reload gdm3 after installation/removal. * Drop old libgnome2-common hack. * Clean up an alternative that is no longer available.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 307f11d..be3ca5d 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
DEFAULT_BACKGROUND=desktop-background
INSTALL=install -m 0644
-BACKGROUNDS=$(wildcard backgrounds/*.png backgrounds/*.jpg backgrounds/*.svg backgrounds/*.tga)
+BACKGROUNDS=$(wildcard backgrounds/*.png backgrounds/*.jpg backgrounds/*.svg backgrounds/*.tga backgrounds/*.xml)
EMBLEMS=$(wildcard emblems/*png emblems/*icon)
SPLASH=$(wildcard splash/*.png splash/*.svg)
PIXMAPS=$(wildcard pixmaps/*.png)
@@ -73,12 +73,14 @@ install:
mkdir -p $(DESTDIR)/usr/share/gnome-background-properties
$(INSTALL) gnome-backgrounds.xml $(DESTDIR)/usr/share/gnome-background-properties/debian.xml
# GDM 3 theme
- mkdir -p $(DESTDIR)/usr/share/gdm/greeter-config
+ mkdir -p $(DESTDIR)/usr/share/gdm/dconf
$(INSTALL) gdm3/background.svg $(DESTDIR)/usr/share/images/desktop-base/login-background.svg
- $(INSTALL) gdm3/10_desktop-base $(DESTDIR)/usr/share/gdm/greeter-config
+ $(INSTALL) gdm3/10-desktop-base-settings $(DESTDIR)/usr/share/gdm/dconf/
# grub
$(INSTALL) grub/joy-grub.png $(DESTDIR)/usr/share/images/desktop-base/
+ $(INSTALL) grub/spacefun-grub.png $(DESTDIR)/usr/share/images/desktop-base/
+ $(INSTALL) grub/spacefun-grub-widescreen.png $(DESTDIR)/usr/share/images/desktop-base/
$(INSTALL) grub/grub_background.sh $(DESTDIR)/usr/share/desktop-base/
# plymouth