summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAurélien COUDERC <zecoucou@free.fr>2019-02-10 09:09:52 +0100
committerAurélien COUDERC <zecoucou@free.fr>2019-02-10 09:09:52 +0100
commit9526d720519014fe09f5e3ab1b58160483266aa2 (patch)
treed75a9d7feca41ef910bdbff514a69406107a1f3e /Makefile
parent0b9024cb41b822846b6d44b8c247aba7bac5ef83 (diff)
Default to wallpaper without logo
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index b775ceb..bfd99a2 100644
--- a/Makefile
+++ b/Makefile
@@ -215,14 +215,17 @@ install-local:
install -d $(DESTDIR)/usr/share/wallpapers
cd $(DESTDIR)/usr/share/wallpapers && ln -s /usr/share/desktop-base/futureprototype-theme/wallpaper FuturePrototype
- ### Lockscreen
- install -d $(DESTDIR)/usr/share/desktop-base/futureprototype-theme/lockscreen/contents/images
- $(INSTALL_DATA) futureprototype-theme/lockscreen/metadata.desktop $(DESTDIR)/usr/share/desktop-base/futureprototype-theme/lockscreen
- $(INSTALL_DATA) futureprototype-theme/lockscreen/gnome-background.xml $(DESTDIR)/usr/share/desktop-base/futureprototype-theme/lockscreen
- $(INSTALL_DATA) $(wildcard futureprototype-theme/lockscreen/contents/images/*) $(DESTDIR)/usr/share/desktop-base/futureprototype-theme/lockscreen/contents/images/
+ ### Lockscreen is using the same image as wallpaper
+ cd $(DESTDIR)/usr/share/desktop-base/futureprototype-theme && ln -s wallpaper lockscreen
+
+ ### Alternate wallpaper with Debian swirl
+ install -d $(DESTDIR)/usr/share/desktop-base/futureprototype-theme/wallpaper-withlogo/contents/images
+ $(INSTALL_DATA) futureprototype-theme/wallpaper-withlogo/metadata.desktop $(DESTDIR)/usr/share/desktop-base/futureprototype-theme/wallpaper-withlogo
+ $(INSTALL_DATA) futureprototype-theme/wallpaper-withlogo/gnome-background.xml $(DESTDIR)/usr/share/desktop-base/futureprototype-theme/wallpaper-withlogo
+ $(INSTALL_DATA) $(wildcard futureprototype-theme/wallpaper-withlogo/contents/images/*) $(DESTDIR)/usr/share/desktop-base/futureprototype-theme/wallpaper-withlogo/contents/images/
# Lock screen symlink for KDE
install -d $(DESTDIR)/usr/share/wallpapers
- cd $(DESTDIR)/usr/share/wallpapers && ln -s /usr/share/desktop-base/futureprototype-theme/lockscreen FuturePrototypeLockScreen
+ cd $(DESTDIR)/usr/share/wallpapers && ln -s /usr/share/desktop-base/futureprototype-theme/wallpaper-withlogo FuturePrototypeWithLogo
# Moonlight theme
### Plymouth theme