summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAurélien COUDERC <zecoucou@free.fr>2016-09-23 23:45:32 +0000
committerAurélien COUDERC <zecoucou@free.fr>2016-09-23 23:45:32 +0000
commitb1313767d0b55054082b4397e0b03b2736ec3d42 (patch)
treebbf2ad78391b8c02866d274ca0a2232f7bf2597c /Makefile
parent1156500b521555e91d41874a3212f0954edb4da6 (diff)
SDDM theming for KDE/Plasma 5
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 1529f0d..d41b006 100644
--- a/Makefile
+++ b/Makefile
@@ -92,7 +92,19 @@ install:
$(INSTALL) $(wildcard ksplash-theme/joy/1920x1080/*) $(DESTDIR)/usr/share/kde4/apps/ksplash/Themes/joy/1920x1080
install -d $(DESTDIR)/usr/share/kde4/apps/ksplash/Themes/joy/1920x1200
$(INSTALL) $(wildcard ksplash-theme/joy/1920x1200/*) $(DESTDIR)/usr/share/kde4/apps/ksplash/Themes/joy/1920x1200
+
+ ## SDDM meta theme (configured with alternatives)
+ install -d $(DESTDIR)/usr/share/sddm/themes/debian-theme
+ $(INSTALL) $(wildcard sddm-debian/*) $(DESTDIR)/usr/share/sddm/themes/debian-theme
+
+
## Lines
+ install -d $(DESTDIR)/usr/share/desktop-base/lines-theme
+ # login background
+ $(INSTALL) lines-theme/login-background.svg $(DESTDIR)/usr/share/desktop-base/lines-theme/
+ $(INSTALL) lines-theme/login-background-with-logo.svg $(DESTDIR)/usr/share/desktop-base/lines-theme/
+ $(INSTALL) lines-theme/sddm-preview.jpg $(DESTDIR)/usr/share/desktop-base/lines-theme/
+
install -d $(DESTDIR)/usr/share/kde4/apps/ksplash/Themes/lines/images
$(INSTALL) $(wildcard ksplash-theme/lines/*.qml) $(DESTDIR)/usr/share/kde4/apps/ksplash/Themes/lines
$(INSTALL) $(wildcard ksplash-theme/lines/*.png) $(DESTDIR)/usr/share/kde4/apps/ksplash/Themes/lines
@@ -106,8 +118,6 @@ install:
# GNOME background descriptor
mkdir -p $(DESTDIR)/usr/share/gnome-background-properties
$(INSTALL) gnome-backgrounds.xml $(DESTDIR)/usr/share/gnome-background-properties/debian.xml
- # login background
- $(INSTALL) login/background.svg $(DESTDIR)/usr/share/images/desktop-base/login-background.svg
# grub
$(INSTALL) grub/lines-grub.png $(DESTDIR)/usr/share/images/desktop-base/