summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAurélien COUDERC <zecoucou@free.fr>2019-01-29 00:14:42 +0100
committerAurélien COUDERC <zecoucou@free.fr>2019-01-29 00:14:42 +0100
commite43094fa37362b475c8039b03739586b05db6004 (patch)
tree771aec75fd41d5b6e9cc1d62cad3b923a6379be4 /Makefile
parentfaef00c0315091c7f1a855dfac007ef8cb2ede4d (diff)
Add futurePrototype theme as Debian buster's default
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile25
1 files changed, 24 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index d1dc82d..5e09103 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-GRUB_THEMES=softwaves-theme/grub lines-theme/grub joy-theme/grub spacefun-theme/grub
+GRUB_THEMES=futureprototype-theme/grub softwaves-theme/grub lines-theme/grub joy-theme/grub spacefun-theme/grub
DEFAULT_BACKGROUND=desktop-background
PIXMAPS=$(wildcard pixmaps/*.png)
@@ -185,4 +185,27 @@ install-local:
install -d $(DESTDIR)/usr/share/wallpapers
cd $(DESTDIR)/usr/share/wallpapers && ln -s /usr/share/desktop-base/softwaves-theme/lockscreen SoftWavesLockScreen
+ # futurePrototype theme (Buster’s default)
+ ### Plymouth theme
+ install -d $(DESTDIR)/usr/share/plymouth/themes/futureprototype
+ $(INSTALL_DATA) $(wildcard futureprototype-theme/plymouth/*) $(DESTDIR)/usr/share/plymouth/themes/futureprototype
+ install -d $(DESTDIR)/usr/share/desktop-base/futureprototype-theme
+ cd $(DESTDIR)/usr/share/desktop-base/futureprototype-theme && ln -s /usr/share/plymouth/themes/futureprototype plymouth
+ ### Login background
+ install -d $(DESTDIR)/usr/share/desktop-base/futureprototype-theme/login
+ $(INSTALL_DATA) $(wildcard futureprototype-theme/login/*) $(DESTDIR)/usr/share/desktop-base/futureprototype-theme/login
+
+ ### Wallpapers
+ install -d $(DESTDIR)/usr/share/desktop-base/futureprototype-theme/wallpaper/contents/images
+ $(INSTALL_DATA) futureprototype-theme/wallpaper/metadata.desktop $(DESTDIR)/usr/share/desktop-base/futureprototype-theme/wallpaper
+ $(INSTALL_DATA) futureprototype-theme/wallpaper/gnome-background.xml $(DESTDIR)/usr/share/desktop-base/futureprototype-theme/wallpaper
+ $(INSTALL_DATA) $(wildcard futureprototype-theme/wallpaper/contents/images/*) $(DESTDIR)/usr/share/desktop-base/futureprototype-theme/wallpaper/contents/images/
+ $(INSTALL_DATA) futureprototype-theme/gnome-wp-list.xml $(DESTDIR)/usr/share/gnome-background-properties/debian-futureprototype.xml
+ # Wallpaper symlink for KDE
+ install -d $(DESTDIR)/usr/share/wallpapers
+ cd $(DESTDIR)/usr/share/wallpapers && ln -s /usr/share/desktop-base/futureprototype-theme/wallpaper FuturePrototype
+
+ ### Lockscreen
+ cd $(DESTDIR)/usr/share/desktop-base/futureprototype-theme && ln -s /usr/share/desktop-base/futureprototype-theme/wallpaper lockscreen
+
include Makefile.inc