summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAurélien COUDERC <zecoucou@free.fr>2017-07-07 10:03:03 +0000
committerAurélien COUDERC <zecoucou@free.fr>2017-07-07 10:03:03 +0000
commitc3ea44ac27f6b0c3d2d685a611731b4c0630e65a (patch)
treeaf3ab9683103c5025453d5a02620beaf5fb4a0ed /debian
parent4a52003a344720e97c4fa9268fa200dcb7fed346 (diff)
Improve detection of grub efi to choose default background ratio.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/postinst7
2 files changed, 12 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 89d5f48..15f530d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+desktop-base (9.0.6) UNRELEASED; urgency=medium
+
+ * Improve detection of grub efi to choose default background ratio.
+
+ -- Aurélien COUDERC <zecoucou@free.fr> Thu, 06 Jul 2017 17:09:44 +0200
+
desktop-base (9.0.5) unstable; urgency=medium
* Ensure postinst doesn’t fails on upgrade even when an incomplete theme pack
diff --git a/debian/postinst b/debian/postinst
index b240074..ebd2118 100644
--- a/debian/postinst
+++ b/debian/postinst
@@ -165,11 +165,16 @@ EOF
# Set up an alternative for the GRUB background/colors config
# Highest priority for active theme
## Favor widescreen / hi-res background for efi installations
- num_grub_efi_installed=$(dpkg-query --list "grub-efi*" 2> /dev/null | grep "^i" | wc -l)
+ grub_installed_query="dpkg-query --list grub-efi*"
+ echo "Detecting installed grub-efi* packages..."
+ ${grub_installed_query} || true # log packages found if any
+ num_grub_efi_installed=$(${grub_installed_query} 2> /dev/null | grep "^i" | wc -l)
if [ $num_grub_efi_installed -gt 0 ] ; then
+ echo "grub-efi found, using 16/9 as default grub background ratio"
grub_first_ratio="16x9"
grub_second_ratio="4x3"
else
+ echo "grub-efi not found, using 4/3 as default grub background ratio"
grub_first_ratio="4x3"
grub_second_ratio="16x9"
fi