summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-11-07 15:49:05 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-07-01 23:53:42 +0100
commitfc2d3815545ae444fa8037021b12d85812a6f75b (patch)
tree1e4e6d2c74ab772da4a6b6a669fa958f2c3967d8
parent94f8f05a2da10771a3403952e3d1b873cc0ce536 (diff)
Increase sqlite_busy_timeout in debpolicy-dbretry
zealot is very slow and we need to give the other processes time to rollback and release the lock.
-rw-r--r--debian/changelog3
-rwxr-xr-xtests/tests/debpolicy-dbretry2
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 1b747fe..93ce3d4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -28,6 +28,9 @@ dgit (1.5~~) unstable; urgency=medium
explicitly in drs-push-rejects test. This avoids date dependencies
which can cause that test to fail on fast computers.
* Remove some spurios .debs from the example_1.0.tar.
+ * Increase sqlite_busy_timeout in debpolicy-dbretry, because
+ zealot is very slow and we need to give the other processes time
+ to rollback and release the lock.
--
diff --git a/tests/tests/debpolicy-dbretry b/tests/tests/debpolicy-dbretry
index d9c2ea2..4122691 100755
--- a/tests/tests/debpolicy-dbretry
+++ b/tests/tests/debpolicy-dbretry
@@ -46,7 +46,7 @@ while ! grep $taint $taintsout; do sleep 0.1; done
DGIT_RPD_TEST_DBLOOP_HOOK='
print STDERR "DBLOOP HOOK $sleepy\n";
- $poldbh->sqlite_busy_timeout(500);
+ $poldbh->sqlite_busy_timeout(2500);
if ($sleepy > 2) {
system '\''
set -ex