summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-13 00:42:26 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-13 00:43:16 +0100
commit0992cbebeb1bcf1dbda34a03917e25ba75fad046 (patch)
treea5f0d95e61c46f442604b4ccc3ec1a992ee8cff8
parente2fa683e96e51f173b17b91f77affa1f7c310867 (diff)
test suite: Do not save non-world-readable artifactsdebian/5.9+exp2archive/debian/5.9+exp2
Save things to $AUTOPKGTEST_ARTIFACTS without preserving access control information. Works around #903680. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog7
-rw-r--r--tests/lib2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index ae3e58d..663eca8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+dgit (5.9+exp2) experimental; urgency=medium
+
+ * test suite: Save things to $AUTOPKGTEST_ARTIFACTS without
+ preserving access control information. Works around #903680.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 13 Jul 2018 00:43:11 +0100
+
dgit (5.9+exp1) experimental; urgency=medium
* test suite: Use dch -r -D sid '' not dch -r sid. Closes:#903441.
diff --git a/tests/lib b/tests/lib
index 87dd376..1ddfcea 100644
--- a/tests/lib
+++ b/tests/lib
@@ -420,7 +420,7 @@ t-save-artifacts () {
if [ x"$artifacts" = x ]; then return; fi
if [ x"tmp" = x ]; then return; fi
: '(((((((((( t-save-artifacts ))))))))))'
- cp -a "$tmp"/. "$artifacts"/.
+ cp -dR --preserve=links,timestamps "$tmp"/. "$artifacts"/.
cd "$artifacts"/.
find . \( -name \*.tar -o -name \*.sample \) -print0 | \
xargs -0r rm -v