summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2023-02-22 14:36:17 -0700
committerSean Whitton <spwhitton@spwhitton.name>2023-02-22 14:57:08 -0700
commitc40f3fd2f2af8573697f5d35eb5261c95283ead8 (patch)
treecc427d8f255b5fd430a9628602ecc65f07699556
parent5ee4728272bac1bcbdd0b1e63e820dc56a371401 (diff)
dgit, dgit-maint-merge(7): Merge README.source text into gen. header
Signed-off-by: Sean Whitton <spwhitton@spwhitton.name>
-rw-r--r--debian/changelog4
-rwxr-xr-xdgit19
-rw-r--r--dgit-maint-merge.7.pod30
3 files changed, 20 insertions, 33 deletions
diff --git a/debian/changelog b/debian/changelog
index 656ebbe..f0ba9ad 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,10 @@
dgit (10.7~) unstable; urgency=medium
* dgit(1), dgit-maint-merge(7): Copy-edit changes since dgit 9.16.
+ * dgit, dgit-maint-merge(7): Merge suggested README.source text into
+ --quilt=single's generated patch header.
+ We now have to say "a workflow similar to ... dgit-maint-merge(7)" but
+ this is worth it for the simplification to the workflow.
--
diff --git a/dgit b/dgit
index f305f48..3cbf8aa 100755
--- a/dgit
+++ b/dgit
@@ -6342,11 +6342,24 @@ sub quilt_fixup_git_singlepatch ($$$) {
if ($o2h) {
quiltify_make_dpkg_patch
$unapplied, $headref,
- 'dgit-changes', '', <<'END', '';
+ 'dgit-changes', '', <<END, '';
Debian changes
-The Debian delta in this package is represented by this one combined patch.
-The git history (e.g. from dgit clone) is the primary source representation.
+The Debian packaging of $package is maintained in git, using a workflow
+similar to the one described in dgit-maint-merge(7).
+The Debian delta is represented by this one combined patch; there isn't a
+patch queue that can be represented as a quilt series.
+
+A detailed breakdown of the changes is available from their canonical
+representation -- git commits in the packaging repository.
+For example, to see the changes made by the Debian maintainer in the first
+upload of upstream version 1.2.3, you could use:
+
+ % git clone https://git.dgit.debian.org/$package
+ % cd $package
+ % git log --oneline 1.2.3..debian/1.2.3-1 -- . ':!debian'
+
+(If you have dgit, use `dgit clone $package`, rather than plain `git clone`.)
We don't use debian/source/options single-debian-patch because it has bugs.
Therefore, NMUs etc. may nevertheless have made additional patches.
diff --git a/dgit-maint-merge.7.pod b/dgit-maint-merge.7.pod
index 07fb9a8..fb30e67 100644
--- a/dgit-maint-merge.7.pod
+++ b/dgit-maint-merge.7.pod
@@ -317,36 +317,6 @@ source:
You don't need to create this file if you are using the version 1.0
source package format.
-=head2 Sample text for debian/README.source
-
-It is a good idea to explain how a user can obtain a breakdown of the
-changes to the upstream source:
-
-=over 4
-
-The Debian packaging of foo is maintained in git,
-using the merging workflow described in dgit-maint-merge(7).
-There isn't a patch queue that can be represented as a quilt series.
-
-A detailed breakdown of the changes is available from their
-canonical representation -
-git commits in the packaging repository.
-For example, to see the changes made by the Debian maintainer in the
-first upload of upstream version 1.2.3, you could use:
-
-=over 4
-
- % git clone https://git.dgit.debian.org/foo
- % cd foo
- % git log --oneline 1.2.3..debian/1.2.3-1 -- . ':!debian'
-
-=back
-
-(If you have dgit, use `dgit clone foo`,
-rather than plain `git clone`.)
-
-=back
-
=head1 BUILDING AND UPLOADING
Use B<dgit build>, B<dgit sbuild>, B<dgit pbuilder>, B<dgit