summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2022-09-04 11:27:06 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2022-09-04 12:36:11 +0100
commitd6ce5696754c895926e122ed9b4690703dcdb78a (patch)
treef5d491efbfdca4bfe1d2aac3ebdd60cd3d8da375
parent2df2d6795e7ef7f34fb9a52236ecc9e8d40145fa (diff)
docs: Update for changes to dgit push-*, and recommend push-source
In command line runes and examples, generally change to "dgit push-source". In running text whwere we talk about "push or push-source", change to "push-built or push-source". In running text where we talk loosely about "push", leave it that way. Closes: #992606 Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--dgit-maint-debrebase.7.pod4
-rw-r--r--dgit-maint-merge.7.pod2
-rw-r--r--dgit-maint-native.7.pod5
-rw-r--r--dgit-nmu-simple.7.pod4
-rw-r--r--dgit-sponsorship.7.pod15
5 files changed, 15 insertions, 15 deletions
diff --git a/dgit-maint-debrebase.7.pod b/dgit-maint-debrebase.7.pod
index b3700a4..6e19026 100644
--- a/dgit-maint-debrebase.7.pod
+++ b/dgit-maint-debrebase.7.pod
@@ -453,7 +453,7 @@ commits just as you would during B<git rebase -i>.
After completing the git rebase, your branch will not be a
fast-forward of the git HEAD you had before the rebase. This means
that we cannot push the branch anywhere. If you are ready to upload,
-B<dgit push> or B<dgit push-source> will take care of fixing this up
+B<dgit push-source> (or B<dgit push-built>) will take care of fixing this up
for you.
If you are not yet ready to upload, and want to push your branch to a
@@ -477,7 +477,7 @@ You can use dpkg-buildpackage(1) for test builds. When you are ready
to build for an upload, use B<dgit sbuild>, B<dgit pbuilder> or B<dgit
cowbuilder>.
-Upload with B<dgit push> or B<dgit push-source>. Remember to pass
+Upload with B<dgit push-source> or B<dgit push-built>. Remember to pass
I<--new> if the package is new in the target suite.
In some cases where you used B<git debrebase convert-from-gbp> since
diff --git a/dgit-maint-merge.7.pod b/dgit-maint-merge.7.pod
index 61399ef..db352f3 100644
--- a/dgit-maint-merge.7.pod
+++ b/dgit-maint-merge.7.pod
@@ -350,7 +350,7 @@ A single combined diff, containing all the changes, follows.
=head1 BUILDING AND UPLOADING
Use B<dgit build>, B<dgit sbuild>, B<dgit pbuilder>, B<dgit
-cowbuilder>, B<dgit push-source>, and B<dgit push> as detailed in
+cowbuilder>, B<dgit push-source>, and B<dgit push-built> as detailed in
dgit(1). If any command fails, dgit will provide a carefully-worded
error message explaining what you should do. If it's not clear, file
a bug against dgit. Remember to pass I<--new> for the first upload.
diff --git a/dgit-maint-native.7.pod b/dgit-maint-native.7.pod
index 792be10..4e8b795 100644
--- a/dgit-maint-native.7.pod
+++ b/dgit-maint-native.7.pod
@@ -58,8 +58,7 @@ Simply prepare your git tree in the usual way, and then:
=over 4
- % dgit -wgf sbuild -A -c sid
- % dgit -wgf --overwrite push
+ % dgit -wgf --overwrite push-source
=back
@@ -94,7 +93,7 @@ your git history.
=over 4
- % dgit -wgf push
+ % dgit -wgf push-source
=back
diff --git a/dgit-nmu-simple.7.pod b/dgit-nmu-simple.7.pod
index 0d2525f..734fb6b 100644
--- a/dgit-nmu-simple.7.pod
+++ b/dgit-nmu-simple.7.pod
@@ -45,8 +45,8 @@ consult the appropriate C<dgit-maint-*(7)> workflow tutorial,
[ run your tests ]
% dch -r && git add debian/changelog && git commit -m"Finalise NMU"
% dgit -wgf sbuild -A -c jessie
- [ final tests on generated .debs ]
- % dgit -wgf [--delayed=5] push jessie
+ [ any final tests on generated .debs ]
+ % dgit -wgf [--delayed=5] push-source jessie
[ enter your gnupg passphrase as prompted ]
[ see that push and upload are successful ]
[ prepare and email NMU diff (git-diff, git-format-patch) ]
diff --git a/dgit-sponsorship.7.pod b/dgit-sponsorship.7.pod
index 2e6f82d..91e70c7 100644
--- a/dgit-sponsorship.7.pod
+++ b/dgit-sponsorship.7.pod
@@ -30,7 +30,7 @@ This section is addressed to the sponsee:
=head2 General
You should prepare the package as if you were going
-to upload it with C<dgit push-source> or C<dgit push> yourself.
+to upload it with C<dgit push-source> or C<dgit push-built> yourself.
For a straightforward NMU, consult L<dgit-nmu-simple(7)>.
@@ -78,7 +78,7 @@ command(s) to generate them.
=item *
-A sample dgit push command, containing
+A sample dgit push-source command, containing
any dgit --quilt=, --gbp or --dpm option needed
=item *
@@ -160,7 +160,7 @@ Some workflows involve git branches which are not natively
dgit-compatible.
Normally dgit will convert them as needed, during push.
-Supply a sample "dgit push" command
+Supply a sample "dgit push-source" command
including any
C<--gbp> (aka C<--quilt=gbp>),
C<--dpm> (aka C<--quilt=dpm>),
@@ -170,7 +170,7 @@ e.g.
=over 4
- % dgit --gbp push
+ % dgit --gbp push-source
=back
@@ -236,7 +236,7 @@ C<dgit -wgf [--quilt=...] sbuild -A -C>
or similar, to to the build, and then
C<dgit -wgf [--quilt=...] push-source>
or
-C<dgit -wgf [--quilt=...] push>
+C<dgit -wgf [--quilt=...] push-built>
to do the upload.
Check whether the sponsee made a debian/I<version> tag.
@@ -306,8 +306,9 @@ formatted as a dgit branch.
When you have finished your review and your tests,
you can do the
-dgit sbuild and
-dgit push directly from the "sponsee" branch.
+dgit push-source
+(or dgit sbuild and dgit push-built)
+directly from the "sponsee" branch.
You will need to pass
C<--overwrite>