summaryrefslogtreecommitdiff
path: root/dgit
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2022-09-03 16:43:43 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2022-09-03 18:12:46 +0100
commitdee0dbe1dff5fc529c2568b08625d3d0afbae2b3 (patch)
tree81bae8541daa335049e9e5ba7bfa8033c37473f4 /dgit
parent7e96270076561f28572fc06fc92e40598198df5c (diff)
dgit: quiltify_make_dpkg_patch: Rename
This is going to stop using dpkg-source. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'dgit')
-rwxr-xr-xdgit6
1 files changed, 3 insertions, 3 deletions
diff --git a/dgit b/dgit
index fd0a852..c53a952 100755
--- a/dgit
+++ b/dgit
@@ -5384,7 +5384,7 @@ our $dscfn;
our $fakeeditorenv = 'DGIT_FAKE_EDITOR_QUILT';
-sub quiltify_dpkg_commit ($$$;$) {
+sub quiltify_make_dpkg_patch ($$$;$) {
my ($patchname,$author,$msg, $xinfo) = @_;
$xinfo //= '';
@@ -5784,7 +5784,7 @@ sub quiltify ($$$$) {
my $ncommits = 3;
my $msg = cmdoutput @git, qw(log), "-n$ncommits";
- quiltify_dpkg_commit "auto-$version-$target-$time",
+ quiltify_make_dpkg_patch "auto-$version-$target-$time",
(getfield $clogp, 'Maintainer'),
(f_ "Automatically generated patch (%s)\n".
"Last (up to) %s git changes, FYI:\n\n",
@@ -5898,7 +5898,7 @@ sub quiltify ($$$$) {
# overwritten.
runcmd @git, qw(checkout -q), $target, qw(debian/changelog);
- quiltify_dpkg_commit "$patchname$index", $author, $msg,
+ quiltify_make_dpkg_patch "$patchname$index", $author, $msg,
"Date: $commitdate\n".
"X-Dgit-Generated: $clogp->{Version} $cc\n";