summaryrefslogtreecommitdiff
path: root/tests/Makefile
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2018-07-31 14:04:58 +0800
committerSean Whitton <spwhitton@spwhitton.name>2018-07-31 14:04:58 +0800
commit3c5614c2292cb2fa1c50915d18510f5c2c915b76 (patch)
tree37703aa7eda0ad83849308db586566c1f23d6fae /tests/Makefile
parente21dbf9b02e32aec335262b2999686c37f01ba00 (diff)
parentf052e1326357a6365a5eddbb985a5b1ef9b4fdb2 (diff)
Merge tag 'debian/6.2' into stretch-bpo
dgit release 6.2 for unstable (sid) [dgit] [dgit distro=debian] # gpg: Signature made Sun 29 Jul 2018 08:02:30 PM CST # gpg: using RSA key 559AE46C2D6B6D3265E7CBA1E3E3392348B50D39 # gpg: Can't check signature: No public key
Diffstat (limited to 'tests/Makefile')
-rw-r--r--tests/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/tests/Makefile b/tests/Makefile
index e6ce153..8494284 100644
--- a/tests/Makefile
+++ b/tests/Makefile
@@ -7,19 +7,12 @@ TESTSCRIPTS ?= $(shell tests/enumerate-tests)
TESTNAMES := $(notdir $(TESTSCRIPTS))
all: $(foreach t,$(TESTNAMES),tests/tmp/$t.ok)
- @echo "ALL PASSED"
-
-tests/tmp:
- mkdir -p $@
+ @echo "ALL PASSED$${DGIT_TESTS_PROGRESSIVE+ AT SOME POINT}"
+tests/tmp/%.ok:
ifeq ($(DGIT_TEST_RETRY_COUNT),)
-
-tests/tmp/%.ok: tests/tmp
tests/tests/$* >tests/tmp/$*.log 2>&1
-
else
-
-tests/tmp/%.ok: tests/tmp
@for retry in $$( seq 1 $(DGIT_TEST_RETRY_COUNT) ); do \
echo "[$$retry] $*"; \
tests/tests/$* >tests/tmp/$*.$$retry.log 2>&1; \
@@ -27,5 +20,5 @@ tests/tmp/%.ok: tests/tmp
if [ $$rc = 0 ]; then exit 0; fi; \
echo >&2 "[$$retry] $* TEST FAILED $$rc"; \
done; exit $$rc
-
endif
+ @touch $@