summaryrefslogtreecommitdiff
path: root/tests/tests
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2018-10-20 10:21:58 -0700
committerSean Whitton <spwhitton@spwhitton.name>2018-10-20 10:21:58 -0700
commit4ea49240ddaa77bb4e290f9018727805ef87efc6 (patch)
treeecc5ef8ce55fa7cce83ebc9554edeb29920ea2cf /tests/tests
parentc1594eccda40a6a40bb2eb330a13578f330b3cc9 (diff)
parent16d99b2680f6c4e41c7740f542ca064455b4f5a4 (diff)
Merge tag 'debian/8.0' into stretch-bpo
dgit release 8.0 for unstable (sid) [dgit] [dgit distro=debian] # gpg: Signature made Sat 13 Oct 2018 04:01:49 PM MST # gpg: using RSA key 559AE46C2D6B6D3265E7CBA1E3E3392348B50D39 # gpg: Can't check signature: No public key
Diffstat (limited to 'tests/tests')
-rwxr-xr-xtests/tests/build-modes-gbp1
-rwxr-xr-xtests/tests/oldnewtagalt2
-rwxr-xr-xtests/tests/push-source2
-rwxr-xr-xtests/tests/push-source-with-changes14
4 files changed, 15 insertions, 4 deletions
diff --git a/tests/tests/build-modes-gbp b/tests/tests/build-modes-gbp
index d99b791..93d0811 100755
--- a/tests/tests/build-modes-gbp
+++ b/tests/tests/build-modes-gbp
@@ -21,6 +21,7 @@ quirk-clean-fixup () {
}
bm_quirk_before_diff=quirk-clean-fixup
+cleanmodes_dpkgsource_extra=,no-check
bm-prep
for act in \
diff --git a/tests/tests/oldnewtagalt b/tests/tests/oldnewtagalt
index 098fe19..6730918 100755
--- a/tests/tests/oldnewtagalt
+++ b/tests/tests/oldnewtagalt
@@ -9,7 +9,7 @@ cd $p
test-push () {
t-commit "$1"
- t-dgit build-source
+ t-dgit -wgf build-source
t-dgit push
}
diff --git a/tests/tests/push-source b/tests/tests/push-source
index f0eafb8..79c4636 100755
--- a/tests/tests/push-source
+++ b/tests/tests/push-source
@@ -12,7 +12,7 @@ cd $p
t-refs-same-start
t-ref-head
-t-dgit --dpkg-buildpackage:-d push-source --new
+t-dgit push-source --new
t-pushed-good master
t-push-was-source-only
diff --git a/tests/tests/push-source-with-changes b/tests/tests/push-source-with-changes
index 580ea3a..aed1b63 100755
--- a/tests/tests/push-source-with-changes
+++ b/tests/tests/push-source-with-changes
@@ -13,14 +13,24 @@ t-ref-head
# (1) try pushing a changes file containing binaries
-t-dgit --dpkg-buildpackage:-d build -F
+t-dgit build -F
t-expect-push-fail 'user-specified changes file is not source-only' \
t-dgit -C ../${p}_1.0_multi.changes push-source --new
# (2) try pushing a source-only changes file
-t-dgit --dpkg-buildpackage:-d build-source
+t-expect-fail F:'tree contains uncommitted files' \
+t-dgit build-source
+
+cp debian/rules{,~}
+git clean -df
+ls debian/rules~
+
+t-expect-fail F:'tree contains uncommitted files' \
+t-dgit -wdda build-source
+
+t-dgit build-source
t-dgit -C ../${p}_1.0_source.changes push-source --new
t-pushed-good master