summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 7c2faac..d334b39 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,8 @@
dgit (3.6~) unstable; urgency=medium
Minor improvements:
- * Call `confess' to print a stack trace when we pass undef to
- shellquote (eg as a result of debugcmd). Turns an undefined
- warning into an explicit internal error.
+ * Use `confess' to print a stack trace in a couple of internal error
+ rcases.
--
diff --git a/dgit b/dgit
index eb42b00..4f85e5c 100755
--- a/dgit
+++ b/dgit
@@ -669,7 +669,7 @@ sub git_get_config ($) {
my ($c) = @_;
foreach my $src (@gitcfgsources) {
my $l = $gitcfgs{$src}{$c};
- croak "$l $c" if $l && !ref $l;
+ confess "internal error ($l $c)" if $l && !ref $l;
printdebug"C $c ".(defined $l ?
join " ", map { messagequote "'$_'" } @$l :
"undef")."\n"