summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit3
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index ce449c7..ee5f7d0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -24,6 +24,8 @@ dgit (1.5~~) unstable; urgency=medium
we rely on --rm-old-changes, or failing that, fail early.
* When doing quilt linearisation, treat upstream .gitignores not
in the toplevel the same way we treat ones in the toplevel.
+ * When automatically generating quilt patch, honour GIT_COMMITTER_DATE
+ for filename creation (makes filename deterministic in test suite).
Infrastructure:
* Better error handling in dgit-repos-policy-debian.
diff --git a/dgit b/dgit
index 352e5b1..bf0d639 100755
--- a/dgit
+++ b/dgit
@@ -2880,7 +2880,8 @@ sub quiltify ($$$$) {
die "$quilt_mode ?";
}
- my $time = time;
+ my $time = $ENV{'GIT_COMMITTER_DATE'} || time;
+ $time =~ s/\s.*//; # trim timezone from GIT_COMMITTER_DATE
my $ncommits = 3;
my $msg = cmdoutput @git, qw(log), "-n$ncommits";