summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit2
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 2417718..eb7bc6a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,9 @@ dgit (4.1~) experimental; urgency=medium
* dgit-user(7): Fixed example rune to use curl (which prints
to stdout, as the rune expects). [reported by Simon Tatham]
+ Minor improvements:
+ * Do not leave many clog-* files in .git/dgit.
+
Internal changes:
* using-these: New script to help with ad-hoc-testing.
* Refactoring in preparation for push-source [Sean Whitton].
diff --git a/dgit b/dgit
index 8b638c4..606abb5 100755
--- a/dgit
+++ b/dgit
@@ -985,7 +985,7 @@ sub commit_getclogp ($) {
my $memo = $commit_getclogp_memo{$objid};
return $memo if $memo;
- my $mclog = dgit_privdir()."clog-$objid";
+ my $mclog = dgit_privdir()."clog";
runcmd shell_cmd "exec >$mclog", @git, qw(cat-file blob),
"$objid:debian/changelog";
$commit_getclogp_memo{$objid} = parsechangelog("-l$mclog");