summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rwxr-xr-xdgit4
2 files changed, 9 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 83f5fc4..a57cd2f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+dgit (0.8) unstable; urgency=low
+
+ * When creating repos in dgit-repos (using the ssh-cmd method),
+ copy _template rather than using mkdir and git init.
+ Closes: #720522.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 23 Aug 2013 12:03:25 +0100
+
dgit (0.7) unstable; urgency=low
* If dak ls, or rmadison, reports multiple versions, look for them
diff --git a/dgit b/dgit
index 4137519..94adcb5 100755
--- a/dgit
+++ b/dgit
@@ -456,9 +456,7 @@ sub create_remote_git_repo () {
runcmd_ordryrun
(access_cfg('ssh'),access_gituserhost(),
"set -e; cd ".access_cfg('git-path').";".
- " mkdir -p $package.git;".
- " cd $package.git;".
- " if ! test -d objects; then git init --bare; fi");
+ " cp -a _template $package.git");
} else {
badcfg "unknown git-create \`$how'";
}