summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Bremner <bremner@debian.org>2023-09-04 06:46:33 -0300
committerDavid Bremner <bremner@debian.org>2023-09-04 07:12:54 -0300
commitb1186a682aa779098b8cfdf96d0d8463b5441c12 (patch)
tree1afee4095f7bb78173129fe07b8529940c398ff6
parent3ce2cc11abf01bd1766d3dfe083bc63e3f8980e6 (diff)
make install helper shellcheck cleandebian/2.1.0archive/debian/2.1.0
mostly quoting, with one ./*
-rw-r--r--debian/changelog3
-rwxr-xr-xhelper/install16
2 files changed, 10 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 62bd99c..f5c016e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,8 +7,9 @@ dh-elpa (2.1.0) experimental; urgency=medium
require a rebuild to fix emacsen-remove scripts, but seems mandated by
policy.
* Add a version to debhelper generated snippets.
+ * Make install helper shellcheck clean
- -- David Bremner <bremner@debian.org> Mon, 04 Sep 2023 06:42:04 -0300
+ -- David Bremner <bremner@debian.org> Mon, 04 Sep 2023 06:53:57 -0300
dh-elpa (2.0.17) unstable; urgency=medium
diff --git a/helper/install b/helper/install
index c0679bb..39db695 100755
--- a/helper/install
+++ b/helper/install
@@ -24,15 +24,15 @@ ELPA_DIR=${ELPA_PACKAGE}-${ELPA_VERSION}
case $FLAVOR in
emacs2[01234]*)
- echo install/${ELPA_DIR}: Skipping obsolete emacs ${FLAVOR}
+ echo "install/${ELPA_DIR}: Skipping obsolete emacs ${FLAVOR}"
exit 0
;;
xemacs*)
- echo install/${ELPA_DIR}: Skipping unsupported emacs ${FLAVOR}
+ echo "install/${ELPA_DIR}: Skipping unsupported emacs ${FLAVOR}"
exit 0
;;
*)
- echo install/${ELPA_DIR}: Handling install of emacsen flavor ${FLAVOR}
+ echo "install/${ELPA_DIR}: Handling install of emacsen flavor ${FLAVOR}"
esac
src_dir=/usr/share/emacs/site-lisp/elpa-src
@@ -42,23 +42,23 @@ elc_dir=/usr/share/${FLAVOR}/site-lisp/elpa/${ELPA_DIR}/
export EMACSLOADPATH
EMACSLOADPATH=${ELPA_LOAD_PATH}
-echo install/${ELPA_DIR}: byte-compiling for ${FLAVOR}
+echo "install/${ELPA_DIR}: byte-compiling for ${FLAVOR}"
-[ -d ${elc_dir} ] || mkdir -p ${elc_dir}
+[ -d "${elc_dir}" ] || mkdir -p "${elc_dir}"
# Create symlinks to the .el files (see section 6E in debian-emacs
# policy). This makes complation easy, and also allows find-function
# and find-library to work properly. Also link all other top level
# files and directories into the flavor directory
-(cd ${elc_dir} && ln -sf ${el_dir}* .)
+(cd "${elc_dir}" && ln -sf "${el_dir}"* .)
# Byte compile them
-(cd ${elc_dir}
+(cd "${elc_dir}"
set +e
${FLAVOR} --quick --batch -l package \
--eval "(setq package-user-dir \"/nonexistent\")" \
--eval "(add-to-list 'package-directory-list \"$src_dir\")" \
- -f package-initialize -f batch-byte-compile *.el > Install.log 2>&1
+ -f package-initialize -f batch-byte-compile ./*.el > Install.log 2>&1
if test $? -ne 0
then
cat Install.log