summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Bremner <bremner@debian.org>2021-09-24 09:25:13 -0300
committerDavid Bremner <bremner@debian.org>2021-09-24 10:17:45 -0300
commitbbd311f58a603a8aa88f1edde0bf364cb98548e7 (patch)
treee9527aae90058507a738d1738f646e399d83c8e1
parent8639bbb456cf24520a534a88720f1db5cc5ed712 (diff)
dh_elpa_test: document options for {dis,en}abling
-rwxr-xr-xdh_elpa_test25
1 files changed, 25 insertions, 0 deletions
diff --git a/dh_elpa_test b/dh_elpa_test
index 2e8ba5f..206ae46 100755
--- a/dh_elpa_test
+++ b/dh_elpa_test
@@ -142,6 +142,31 @@ example, the B<ert_eval> configuration key replaced environment
variable B<DH_ELPA_TEST_ERT_EVAL>. Their use is now deprecated. If
the debian/elpa-test file exists, they will be ignored.
+=head1 CONTROLLING INVOCATION
+
+The following recipes can be combined to enable an appropriate
+combination of build time and autopkgtest time tests.
+
+=head2 DISABLING BUILD TIME TESTS
+
+To disable running tests at build time, you have two choices. You can
+override B<dh_elpa_test> (not B<dh_auto_test>), or you can use the
+B<disable> key in B<debian/elpa-test>. Note that the latter will also
+(mostly) disable autopkgtests (see below).
+
+=head2 ENABLING AUTOPKGTESTS
+
+To enable running autopkgtests via B<dh_elpa_test>, add "Testsuite:
+autpkgtest-pkg-elpa" to B<debian/rules>. With B<disable> in
+B<debian/elpa-test>, only B<superficial> tests, namely installing the
+binary packages and byte-compiling any that use B<dh_elpa>.
+
+=head2 ENABLING DH_AUTO_TEST
+
+By default B<dh_elpa_test> replaces B<dh_auto_test>. You can re-enable
+B<dh_auto_test> either with the B<disable> key discussed above, or by
+overriding B<dh_elpa_test> to call B<dh_auto_test>.
+
=cut
use File::Find::Rule;