summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-04-10 08:15:54 -0700
committerSean Whitton <spwhitton@spwhitton.name>2016-04-10 08:15:54 -0700
commit4ee6e92c977d60ed66ed5e9e7d3e19d93f947c8a (patch)
treef775a0af06b6db5b43ddcd9b38b270971e96bfa9 /debian
parenta3eb8c6aa39be5cd2f27bd6f21156fad8c2b6e5e (diff)
merge (unreleased) src:dh-elpa-test into dh-elpa
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/control10
-rw-r--r--debian/copyright1
-rw-r--r--debian/install1
-rwxr-xr-xdebian/rules6
5 files changed, 16 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 3690c07..fef0560 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,11 @@ dh-elpa (0.0.20) UNRELEASED; urgency=medium
[ Sean Whitton ]
* Add yasnippet to list of packages maintained outside of the elpa-*
binary package namespace.
+ * Add dh_elpa_test helper and elpa_plus_test.pm sequencer script, plus
+ documentation, new dependencies and installation code. dh_elpa can
+ now automatically detect and run Buttercup and ERT test suites.
+ * Use https for Vcs-* control file fields.
+ * Add myself as an uploader.
-- Sean Whitton <spwhitton@spwhitton.name> Wed, 16 Mar 2016 19:16:15 -0700
diff --git a/debian/control b/debian/control
index 94b57f4..de7bfa5 100644
--- a/debian/control
+++ b/debian/control
@@ -2,17 +2,17 @@ Source: dh-elpa
Section: devel
Priority: optional
Maintainer: Debian Emacs addons team <pkg-emacsen-addons@lists.alioth.debian.org>
-Uploaders: David Bremner <bremner@debian.org>
-Build-Depends: debhelper (>=9.20151004),
+Uploaders: David Bremner <bremner@debian.org>, Sean Whitton <spwhitton@spwhitton.name>
+Build-Depends: debhelper (>=9.20151004),
emacs24-nox | emacs24 (>=24~) | emacs24-lucid (>=24~)
Standards-Version: 3.9.6
-Vcs-Git: git://anonscm.debian.org/pkg-emacsen/pkg/dh-elpa.git
-Vcs-Browser: http://anonscm.debian.org/cgit/pkg-emacsen/pkg/dh-elpa.git/
+Vcs-Git: https://anonscm.debian.org/pkg-emacsen/pkg/dh-elpa.git
+Vcs-Browser: https://anonscm.debian.org/cgit/pkg-emacsen/pkg/dh-elpa.git/
Package: dh-elpa
Architecture: all
Built-Using: ${misc:Built-Using}
-Depends: ${misc:Depends}, ${perl:Depends}, emacs24-nox | emacs24 (>=24~) | emacs24-lucid (>=24~)
+Depends: ${misc:Depends}, ${perl:Depends}, emacs24-nox | emacs24 (>=24~) | emacs24-lucid (>=24~), dh-make-perl (>= 0.90), libarray-utils-perl, libtext-glob-perl
Description: Debian helper tools for packaging emacs lisp extensions
This package provides a helper for packaging emacs lisp extensions
in a way compatible with the GNU Emacs 'elpa' package repository.
diff --git a/debian/copyright b/debian/copyright
index 4f236de..47c7357 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -3,6 +3,7 @@ Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Files: *
Copyright: © 2007-2015 Free Software Foundation Inc,
© 2015 David Bremner <bremner@debian.org>
+ © 2016 Sean Whitton <spwhitton@spwhitton.name>
License: GPL-3+
dh-elpa is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
diff --git a/debian/install b/debian/install
index 7730e3d..35b1239 100644
--- a/debian/install
+++ b/debian/install
@@ -1,3 +1,4 @@
usr/bin
emacsen-common usr/share/debhelper/dh_elpa
elpa.pm usr/share/perl5/Debian/Debhelper/Sequence
+elpa_plus_test.pm usr/share/perl5/Debian/Debhelper/Sequence
diff --git a/debian/rules b/debian/rules
index ccb9394..ecdc57e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,13 +7,15 @@ VERSION=$(shell dpkg-parsechangelog | sed -n 's/^Version: //p')
override_dh_auto_build:
pod2man -c Debhelper --section=1 dh_elpa.in > dh_elpa.1
+ pod2man -c Debhelper --section=1 dh_elpa_test > dh_elpa_test.1
sed s/@HELPER_VERSION@/${VERSION}/ < dh_elpa.in > dh_elpa
- chmod 755 dh_elpa
+ chmod 755 dh_elpa dh_elpa_test
override_dh_install:
dh_install
- dh_installman dh_elpa.1
+ dh_installman dh_elpa.1 dh_elpa_test.1
./dh_elpa --no-byte-compile
override_dh_auto_install:
install -m 755 -D dh_elpa $(DESTDIR)/usr/bin/dh_elpa
+ install -m 755 -D dh_elpa_test $(DESTDIR)/usr/bin/dh_elpa_test