summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xhelper/install5
-rwxr-xr-xhelper/remove5
3 files changed, 15 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 9c20cd9..dc7c972 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,13 +2,17 @@ dh-elpa (2.0.16) UNRELEASED; urgency=medium
* Drop dependencies on emacs-el introduced in 2.0.11.
Emacs itself now has this dependency. It's required for native-comp.
+ * install/remove: Export EMACS_INHIBIT_AUTOMATIC_NATIVE_COMPILATION=t.
+ This is likely temporary, pending updates to emacsen-common.
+
* dh_elpa_test: Revert changes in 2.0.12, 2.0.13 and 2.0.14.
* dh_elpa_test: Export EMACS_INHIBIT_AUTOMATIC_NATIVE_COMPILATION=t.
Unconditionally prevent native comp writing to HOME while running tests.
- - Tighten dependency on emacs-nox|emacs to require >= 1:28.2+1-9.
* dh_elpa_test: Replace use of smartmatch operator.
It is expected that Perl upstream will soon deprecate the operator.
+ * Tighten dependency on emacs-nox|emacs to require >= 1:28.2+1-9.
+
-- Sean Whitton <spwhitton@spwhitton.name> Sun, 27 Nov 2022 11:40:32 -0700
dh-elpa (2.0.15) unstable; urgency=medium
diff --git a/helper/install b/helper/install
index 79a9adb..3152cf4 100755
--- a/helper/install
+++ b/helper/install
@@ -3,6 +3,11 @@
set -e
+# Avoid writes to HOME.
+# This should probably move into bin:emacsen-common.
+EMACS_INHIBIT_AUTOMATIC_NATIVE_COMPILATION=t
+export EMACS_INHIBIT_AUTOMATIC_NATIVE_COMPILATION
+
# safe values for important variables
unset HOME
diff --git a/helper/remove b/helper/remove
index 9a980e9..3182eeb 100755
--- a/helper/remove
+++ b/helper/remove
@@ -4,6 +4,11 @@
set -e
+# Avoid writes to HOME.
+# This should probably move into bin:emacsen-common.
+EMACS_INHIBIT_AUTOMATIC_NATIVE_COMPILATION=t
+export EMACS_INHIBIT_AUTOMATIC_NATIVE_COMPILATION
+
# safe values for important variables
unset HOME