summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--debian/README.Debian4
-rwxr-xr-xdebian/postinst18
-rwxr-xr-xdebian/prerm8
4 files changed, 6 insertions, 26 deletions
diff --git a/Makefile b/Makefile
index 813883d..0339356 100644
--- a/Makefile
+++ b/Makefile
@@ -94,7 +94,7 @@ install-doc:
## Our and web servers configuration under /etc
install-conf:
install -D --mode=644 config/dhelp.conf-sample $(confdir)/dhelp.conf
- install -D --mode=644 config/apache-dhelp.conf $(confdir)/apache2/conf.d/dhelp
+ install -D --mode=644 config/apache-dhelp.conf $(confdir)/apache2/conf.d/dhelp.conf
install -D --mode=644 config/apache-dhelp.conf $(confdir)/apache2/conf-available/dhelp.conf
install -D --mode=644 config/lighttpd-dhelp.conf $(confdir)/lighttpd/conf-available/95-dhelp.conf
diff --git a/debian/README.Debian b/debian/README.Debian
index 266c75d..8e444e4 100644
--- a/debian/README.Debian
+++ b/debian/README.Debian
@@ -91,7 +91,7 @@ apache2 : A configuration snippet is installed during dhelp installation.
Action : Uncomment the `Alias /doc/ ...' line inside the installed dhelp
configuration snippet for apache2. Its path depends on apache2
version.
- < 2.4 : /etc/apache2/conf.d/dhelp
+ < 2.4 : /etc/apache2/conf.d/dhelp.conf
>= 2.4 : /etc/apache2/conf-available/dhelp.conf
------------------------------------------------------------------------------
@@ -105,7 +105,7 @@ mini-httpd : Does not support aliases. Action : cf. [1] below.
------------------------------------------------------------------------------
monkey : Does not support aliases.
- [1] Action : Create a symlink named `doc' to `/usr/sharedoc', inside
+ [1] Action : Create a symlink named `doc' to `/usr/share/doc', inside
the web server's document root (Debian default is /var/www).
The command to create it is:
diff --git a/debian/postinst b/debian/postinst
index 8ba7fc3..01d99ac 100755
--- a/debian/postinst
+++ b/debian/postinst
@@ -30,7 +30,6 @@ DHELP_APTHOOK=/etc/apt/apt.conf.d/35dhelp
DHELP_POSTCMD='Dpkg::Post-Invoke {
"if test -x '${DHELP_INDEXER}'; then '${DHELP_INDEXER}'; fi";
};'
-DHELP_CONFDIR=/usr/share/dhelp/config
DHELP_OKINDEX="false"
#### Import Library ####
@@ -164,20 +163,9 @@ configure|abort-upgrade)
"and run 'dhelp_parse -r' to retry the build process."
fi
- # Apache2: copy in both locations, ie for versions < 2.4 and >= 2.4
-
- cp_ucfregister_file dhelp ${DHELP_CONFDIR}/apache-dhelp.conf \
- /etc/apache2/conf.d/dhelp.conf
- cp_ucfregister_file dhelp ${DHELP_CONFDIR}/apache-dhelp.conf \
- /etc/apache2/conf-available/dhelp.conf
-
- try_chconf_apache2 "enable" dhelp || true
-
- # Lighttpd:
-
- cp_ucfregister_file dhelp ${DHELP_CONFDIR}/lighttpd-dhelp.conf \
- /etc/lighttpd/conf-available/95-dhelp.conf
+ # Try to enable web server configs (at most one is expected to succeed)
+ try_chconf_apache2 "enable" dhelp || true
try_chconf_lighttpd "enable" dhelp || true
# Create the full text search index at the end of postinst.
@@ -202,5 +190,5 @@ configure|abort-upgrade)
esac
unset DHELP_INDEXER DHELP_POSTCMD DHELP_APTHOOK || true
-unset DHELP_CONFDIR DHELP_LIBFILE DHELP_OKINDEX || true
+unset DHELP_LIBFILE DHELP_OKINDEX || true
diff --git a/debian/prerm b/debian/prerm
index 0e8e3e4..9c3a31d 100755
--- a/debian/prerm
+++ b/debian/prerm
@@ -99,13 +99,6 @@ esac
case $1 in
purge)
- # Remove and unregister with ucf our web server configuration snippets.
-
- ucf_unregister_file dhelp /etc/apache2/conf.d/dhelp.conf
- ucf_unregister_file dhelp /etc/apache2/conf-available/dhelp.conf
-
- ucf_unregister_file dhelp /etc/lighttpd/conf-available/95-dhelp.conf
-
# Remove and unregister with ucf our dpkg post-invoke hook.
ucf_unregister_file dhelp ${DHELP_APTHOOK}
@@ -115,4 +108,3 @@ purge)
esac
unset DHELP_APTHOOK DHELP_LIBFILE || true
-