summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Hilbrich <torsten.hilbrich@gmx.net>2004-10-02 08:31:00 +0200
committerTorsten Hilbrich <torsten@hilbrich.net>2011-08-27 20:47:38 +0200
commit73347f4e6674220348ec2294cde19ae25819986b (patch)
treec8f1ce6335973f531f22ebcc5146abda628b6211
parent988ccf5d91893fd5624f1ca6a8805a0ed31bd090 (diff)
Imported version 1.8.7 from tarball
fixed decoding problem when selecting dictionary (problem reported by Kuno Strassmann)
-rwxr-xr-x[-rw-r--r--]GPL0
-rwxr-xr-x[-rw-r--r--]Makefile22
-rwxr-xr-x[-rw-r--r--]README0
-rwxr-xr-x[-rw-r--r--]connection.el0
-rwxr-xr-x[-rw-r--r--]deb/README.debian0
-rwxr-xr-x[-rw-r--r--]deb/changelog7
-rwxr-xr-x[-rw-r--r--]deb/control0
-rwxr-xr-x[-rw-r--r--]deb/copyright0
-rwxr-xr-x[-rw-r--r--]deb/dirs0
-rwxr-xr-x[-rw-r--r--]dictionary-init.el0
-rwxr-xr-x[-rw-r--r--]dictionary.el8
-rwxr-xr-x[-rw-r--r--]install-package.el0
-rwxr-xr-x[-rw-r--r--]link.el0
-rwxr-xr-x[-rw-r--r--]lpath.el0
14 files changed, 34 insertions, 3 deletions
diff --git a/GPL b/GPL
index 60549be..60549be 100644..100755
--- a/GPL
+++ b/GPL
diff --git a/Makefile b/Makefile
index c16bf84..db7ad5f 100644..100755
--- a/Makefile
+++ b/Makefile
@@ -10,6 +10,14 @@ XEMACS-PACKAGE=$(PACKAGE)-$(VERSION)-pkg.tar.gz
SOURCES=dictionary.el connection.el link.el
COMPILED=dictionary.elc connection.elc link.elc
+# For make dist
+LISP_FILES=connection.el dictionary.el link.el lpath.el dictionary-init.el \
+ install-package.el
+DOC_FILES=README GPL Makefile
+DEB_FILES=README.debian control copyright install.debian postinst \
+ prerm remove.debian rules changelog dirs
+DEB_DIR=deb
+
.SUFFIXES: .elc .el
.el.elc:
@@ -78,6 +86,20 @@ html: doc/dictionary
doc/dictionary: doc/dictionary.texi
cd doc && makeinfo --html dictionary
+.PHONY: dist
+dist:
+ @[ -x debian ] || ln -s deb debian; \
+ VERSION=$$(dpkg-parsechangelog | perl -n -e '/^Version: (.*)-/ && print "$$1\n"'); \
+ DIR=$$(mktemp -d); \
+ DESTDIR="$$DIR/dictionary-$$VERSION"; \
+ install -d $$DESTDIR; \
+ install $(LISP_FILES) $(DOC_FILES) $$DESTDIR; \
+ mkdir $$DESTDIR/$(DEB_DIR); \
+ cd $(DEB_DIR) && install $(DEB_FILES) $$DESTDIR/$(DEB_DIR); \
+ tar czf $(CURDIR)/dictionary-$$VERSION.tar.gz -C $$DIR .; \
+ rm -r $$DIR; \
+ echo "dictionary-$$VERSION.tar.gz has been created"
+
.PHONY: clean
clean:
rm -f $(XEMACS-PACKAGE) $(COMPILED) build
diff --git a/README b/README
index cddcbf7..cddcbf7 100644..100755
--- a/README
+++ b/README
diff --git a/connection.el b/connection.el
index 42b7bbb..42b7bbb 100644..100755
--- a/connection.el
+++ b/connection.el
diff --git a/deb/README.debian b/deb/README.debian
index d5bf0de..d5bf0de 100644..100755
--- a/deb/README.debian
+++ b/deb/README.debian
diff --git a/deb/changelog b/deb/changelog
index 980f9b7..2c6d6d2 100644..100755
--- a/deb/changelog
+++ b/deb/changelog
@@ -1,3 +1,10 @@
+dictionary (1.8.7-1) unstable; urgency=low
+
+ * fixed decoding problem when selecting dictionary (problem reported by
+ Kuno Strassmann)
+
+ -- Torsten Hilbrich <dictionary@myrkr.in-berlin.de> Sat, 2 Oct 2004 08:05:37 +0200
+
dictionary (1.8.6-1) unstable; urgency=low
* added patch fixing the wrong display of dictionary description
diff --git a/deb/control b/deb/control
index fed4dd5..fed4dd5 100644..100755
--- a/deb/control
+++ b/deb/control
diff --git a/deb/copyright b/deb/copyright
index b82cc97..b82cc97 100644..100755
--- a/deb/copyright
+++ b/deb/copyright
diff --git a/deb/dirs b/deb/dirs
index 9d129ef..9d129ef 100644..100755
--- a/deb/dirs
+++ b/deb/dirs
diff --git a/dictionary-init.el b/dictionary-init.el
index 540dfc3..540dfc3 100644..100755
--- a/dictionary-init.el
+++ b/dictionary-init.el
diff --git a/dictionary.el b/dictionary.el
index 896b682..3270616 100644..100755
--- a/dictionary.el
+++ b/dictionary.el
@@ -2,7 +2,7 @@
;; Author: Torsten Hilbrich <dictionary@myrkr.in-berlin.de>
;; Keywords: interface, dictionary
-;; $Id: dictionary.el,v 1.38 2004/03/05 08:08:30 torsten Exp $
+;; $Id: dictionary.el 338 2004-10-02 06:04:54Z torsten $
;; This file is free software; you can redistribute it and/or modify
;; it under the terms of the GNU General Public License as published by
@@ -829,10 +829,12 @@ If PATTERN is omitted, it defaults to \"[ \\f\\t\\n\\r\\v]+\"."
"Display a single dictionary"
(let* ((list (dictionary-split-string string))
(dictionary (car list))
- (description (cadr list)))
+ (description (cadr list))
+ (translated (dictionary-decode-charset description dictionary)))
(if dictionary
(progn
- (link-insert-link description 'dictionary-reference-face
+ (link-insert-link (concat dictionary ": " translated)
+ 'dictionary-reference-face
'dictionary-set-dictionary
(cons dictionary description)
"Mouse-2 to select this dictionary")
diff --git a/install-package.el b/install-package.el
index 5b0474e..5b0474e 100644..100755
--- a/install-package.el
+++ b/install-package.el
diff --git a/link.el b/link.el
index 580dba2..580dba2 100644..100755
--- a/link.el
+++ b/link.el
diff --git a/lpath.el b/lpath.el
index 858179f..858179f 100644..100755
--- a/lpath.el
+++ b/lpath.el