summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2017-01-05 18:50:00 -0500
committerAaron M. Ucko <ucko@debian.org>2017-01-05 18:50:00 -0500
commit826054a191483c7f47df0de8752e1b1282631a28 (patch)
tree26f9ada3debc725dc1df841650d23f04c704704b
parent21aaa6f179e612334e5e40ae3ebeca2feef1446e (diff)
dictionary.el: toggle-read-only -> buffer-read-only (#850279)
Per Hermógenes Oliveira <oliveira-guest@alioth.debian.org>, adjust buffer-read-only rather than calling toggle-read-only, which is deprecated and can have unwanted side effects. (Closes: #850279.)
-rw-r--r--debian/changelog5
-rwxr-xr-xdictionary.el4
2 files changed, 6 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 3eae1d8..7326665 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,11 @@
dictionary-el (1.10-3) UNRELEASED; urgency=medium
* NOT RELEASED YET.
+ * dictionary.el: Per Hermógenes Oliveira <oliveira-guest@alioth.debian.org>,
+ adjust buffer-read-only rather than calling toggle-read-only, which is
+ deprecated and can have unwanted side effects. (Closes: #850279.)
- -- Aaron M. Ucko <ucko@debian.org> Thu, 05 Jan 2017 18:47:45 -0500
+ -- Aaron M. Ucko <ucko@debian.org> Thu, 05 Jan 2017 18:49:59 -0500
dictionary-el (1.10-2) unstable; urgency=medium
diff --git a/dictionary.el b/dictionary.el
index a5885c3..9c77e8b 100755
--- a/dictionary.el
+++ b/dictionary.el
@@ -679,7 +679,7 @@ This function knows about the special meaning of quotes (\")"
(defun dictionary-pre-buffer ()
"These commands are executed at the begin of a new buffer"
- (toggle-read-only 0)
+ (setq buffer-read-only nil)
(erase-buffer)
(if dictionary-create-buttons
(progn
@@ -722,7 +722,7 @@ This function knows about the special meaning of quotes (\")"
(goto-char dictionary-marker)
(set-buffer-modified-p nil)
- (toggle-read-only 1))
+ (setq buffer-read-only t))
(defun dictionary-display-search-result (reply)
"This function starts displaying the result starting with the `reply'."