summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2017-01-05 21:32:36 -0500
committerAaron M. Ucko <ucko@debian.org>2017-01-05 21:32:36 -0500
commit460e34451140817b289dfa252582bbe08100c6e8 (patch)
tree24004a7e34179b716ba7ac9a534b1ca46d782f78 /debian/rules
parent85fb4a5ce34b02690a94e276daed220edeceea49 (diff)
dictionary-el (1.10-3) unstable; urgency=medium
* debian/control: Canonicalize per cme. In particular, declare Standards-Version: 3.9.8 (already compliant, in fact). * dictionary.el: - Per Hermógenes Oliveira <oliveira-guest@alioth.debian.org>, adjust buffer-read-only rather than calling toggle-read-only, which is deprecated and can have unwanted side effects. (Closes: #850279.) - Per the ever-patient Kevin Ryde <user42@zip.com.au>, adjust dictionary-tooltip-dictionary's defcustom type to acknowledge that nil (the default value) is in fact valid. (Closes: #719041.) Also, tweak dictionary-display-tooltip (used by GNU Emacs) to proceed even if dictionary-tooltip-dictionary is nil, as already done for XEmacs. [dgit import package dictionary-el 1.10-3]
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..233c191
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+instdir=debian/dictionary-el/usr/share/emacs/site-lisp/dictionary-el
+
+%:
+ dh $@
+
+override_dh_auto_build: ;
+
+override_dh_install:
+ install -m644 *.el $(instdir)
+ rm $(instdir)/lpath.el