summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrmanfredi <rmanfredi@2592e710-e01b-42a5-8df0-11608a6cc53d>2014-04-05 08:19:48 +0000
committerrmanfredi <rmanfredi@2592e710-e01b-42a5-8df0-11608a6cc53d>2014-04-05 08:19:48 +0000
commit8ec557b6a0ded6338c92471a208758ae2ad6fdcb (patch)
treeb39782b5d551a8e568ffee371871fe5346f2d1e5
parent0d4893ddc60f31485fbcfbe813871e386a933e49 (diff)
Added LinkSourceFileAlias() and added depend/realclean to LinkSourceFile().
git-svn-id: svn://svn.code.sf.net/p/dist/code/trunk/dist@174 2592e710-e01b-42a5-8df0-11608a6cc53d
-rwxr-xr-xjmake/Makefile.SH2
-rw-r--r--jmake/files/Jmake.rules22
2 files changed, 22 insertions, 2 deletions
diff --git a/jmake/Makefile.SH b/jmake/Makefile.SH
index b4fe586..76a7182 100755
--- a/jmake/Makefile.SH
+++ b/jmake/Makefile.SH
@@ -64,7 +64,7 @@ $spitshell >>Makefile <<'!NO!SUBS!'
########################################################################
# Start of Jmakefile
-# $X-Id: Jmakefile 48 2010-11-28 23:05:09Z rmanfredi $
+# $X-Id: Jmakefile 173 2014-04-05 08:10:18Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
diff --git a/jmake/files/Jmake.rules b/jmake/files/Jmake.rules
index e81d291..af53c13 100644
--- a/jmake/files/Jmake.rules
+++ b/jmake/files/Jmake.rules
@@ -1140,8 +1140,28 @@ NormalLintTarget($(SOURCES)) @!\
*/
#define LinkSourceFile(src,dir) @!\
src: dir/src @@\
- $(RM) $@ @@\
+ $(RM) -f $@ @@\
$(LN) $? $@ @!\
+ @!\
+local_depend:: src @@\
+ @!\
+local_realclean:: @@\
+ $(RM) -f src @!\
+
+
+/*
+ * LinkSourceFileAlias:
+ * Snag source file from some other directory with a different local name.
+ */
+#define LinkSourceFileAlias(src,dir,alias) @!\
+alias: dir/src @@\
+ $(RM) -f $@ @@\
+ $(LN) $? $@ @!\
+ @!\
+local_depend:: alias @@\
+ @!\
+local_realclean:: @@\
+ $(RM) -f alias @!\
/*