summaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorrmanfredi <rmanfredi@2592e710-e01b-42a5-8df0-11608a6cc53d>2010-11-28 23:05:09 +0000
committerrmanfredi <rmanfredi@2592e710-e01b-42a5-8df0-11608a6cc53d>2010-11-28 23:05:09 +0000
commit36a47742bb84eb86d0a1095bbbefd6e905f39d4f (patch)
tree21e21ebb1aee2bbf99a0a048e370fedfd7d92884 /bin
parent17a95c14fc05fe53f250d627b55ea588321c7129 (diff)
Added the notion of local_depend and sub_depend.
This allows one to do a "make local_depend" after Makefile.SH extraction without having to recurse to subdirs. git-svn-id: svn://svn.code.sf.net/p/dist/code/trunk/dist@48 2592e710-e01b-42a5-8df0-11608a6cc53d
Diffstat (limited to 'bin')
-rw-r--r--bin/Jmakefile3
-rwxr-xr-xbin/Makefile.SH18
2 files changed, 16 insertions, 5 deletions
diff --git a/bin/Jmakefile b/bin/Jmakefile
index aac4157..0f13799 100644
--- a/bin/Jmakefile
+++ b/bin/Jmakefile
@@ -30,7 +30,8 @@ BINSH = \
!f.SH \
-expand \\
-depend::
+depend:: local_depend
+local_depend::
($(SED) '/^# DO NOT DELETE/q' Makefile && \
grep '^\$$grep' $(BINSH) | \
$(SED) -e "s/^.*' \([^ ]*\) >>[ ]*\([^ ]*\)/\2: \1/" \
diff --git a/bin/Makefile.SH b/bin/Makefile.SH
index 35630ec..492267c 100755
--- a/bin/Makefile.SH
+++ b/bin/Makefile.SH
@@ -1,5 +1,5 @@
-: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5 PL0]
-: $X-Id: Jmake.tmpl 8 2006-08-25 22:27:18Z rmanfredi $
+: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5-43]
+: $X-Id: Jmake.tmpl 47 2010-11-28 22:23:13Z rmanfredi $
case $CONFIG in
'')
@@ -58,7 +58,7 @@ SCRIPTS = \$(BIN)
$spitshell >>Makefile <<'!NO!SUBS!'
########################################################################
# Jmake rules for building libraries, programs, scripts, and data files
-# $X-Id: Jmake.rules 8 2006-08-25 22:27:18Z rmanfredi $
+# $X-Id: Jmake.rules 18 2006-12-27 10:35:09Z rmanfredi $
########################################################################
# Start of Jmakefile
@@ -138,7 +138,8 @@ BINSH = \
packinit.SH \
manilist.SH
-depend::
+depend:: local_depend
+local_depend::
($(SED) '/^# DO NOT DELETE/q' Makefile && \
grep '^\$$grep' $(BINSH) | \
$(SED) -e "s/^.*' \([^ ]*\) >>[ ]*\([^ ]*\)/\2: \1/" \
@@ -206,6 +207,8 @@ tags::
local_clobber::
$(RM) tags
+depend::
+
########################################################################
# Empty rules for directories with no sub-directories -- do not edit
@@ -225,6 +228,13 @@ Makefiles::
Makefiles.SH::
+########################################################################
+# Dependencies generated by make depend
+# DO NOT DELETE THIS LINE -- make depend relies on it
+
+# Put nothing here or make depend will gobble it up
+.FORCE_DEPEND::
+ @echo "You must run 'make depend' in $(TOP) first."; exit 1
!NO!SUBS!
chmod 644 Makefile
$eunicefix Makefile