summaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@golden-gryphon.com>2014-04-27 17:54:01 -0700
committerManoj Srivastava <srivasta@golden-gryphon.com>2014-04-27 17:54:01 -0700
commit8f5e5726134ce5b4bd436b16f367796d851df553 (patch)
tree0ce2ad130721dcf917d7f81fb8495bf0a189d266 /bin
parent02bf7be6fc0f798790ef5b2160bc89a77b909428 (diff)
Imported Upstream version 3.5-36
Diffstat (limited to 'bin')
-rw-r--r--bin/Jmakefile5
-rwxr-xr-xbin/Makefile.SH20
-rwxr-xr-xbin/manilist.SH4
-rwxr-xr-xbin/packinit.SH4
-rwxr-xr-xbin/perload4
-rwxr-xr-xbin/svn-revision5
6 files changed, 27 insertions, 15 deletions
diff --git a/bin/Jmakefile b/bin/Jmakefile
index 3ed908a..a3cf78b 100644
--- a/bin/Jmakefile
+++ b/bin/Jmakefile
@@ -2,7 +2,7 @@
* Jmakefile for bin subdirectory.
*/
-;# $Id: Jmakefile 9 2006-08-25 22:31:50Z rmanfredi $
+;# $Id: Jmakefile 48 2010-11-28 23:05:09Z rmanfredi $
;#
;# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
;#
@@ -30,7 +30,8 @@ BINSH = \
!f.SH \
-expand \\
-depend::
+depend:: local_depend
+local_depend::
($(SED) '/^# DO NOT DELETE/q' Makefile && \
grep '^\$$grep' $(BINSH) | \
$(SED) -e "s/^.*' \([^ ]*\) >>[ ]*\([^ ]*\)/\2: \1/" \
diff --git a/bin/Makefile.SH b/bin/Makefile.SH
index 35630ec..89aaec1 100755
--- a/bin/Makefile.SH
+++ b/bin/Makefile.SH
@@ -1,5 +1,5 @@
-: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5 PL0]
-: $X-Id: Jmake.tmpl 8 2006-08-25 22:27:18Z rmanfredi $
+: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5-43]
+: $X-Id: Jmake.tmpl 47 2010-11-28 22:23:13Z rmanfredi $
case $CONFIG in
'')
@@ -58,12 +58,12 @@ SCRIPTS = \$(BIN)
$spitshell >>Makefile <<'!NO!SUBS!'
########################################################################
# Jmake rules for building libraries, programs, scripts, and data files
-# $X-Id: Jmake.rules 8 2006-08-25 22:27:18Z rmanfredi $
+# $X-Id: Jmake.rules 18 2006-12-27 10:35:09Z rmanfredi $
########################################################################
# Start of Jmakefile
-# $X-Id: Jmakefile 9 2006-08-25 22:31:50Z rmanfredi $
+# $X-Id: Jmakefile 48 2010-11-28 23:05:09Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
@@ -138,7 +138,8 @@ BINSH = \
packinit.SH \
manilist.SH
-depend::
+depend:: local_depend
+local_depend::
($(SED) '/^# DO NOT DELETE/q' Makefile && \
grep '^\$$grep' $(BINSH) | \
$(SED) -e "s/^.*' \([^ ]*\) >>[ ]*\([^ ]*\)/\2: \1/" \
@@ -206,6 +207,8 @@ tags::
local_clobber::
$(RM) tags
+depend::
+
########################################################################
# Empty rules for directories with no sub-directories -- do not edit
@@ -225,6 +228,13 @@ Makefiles::
Makefiles.SH::
+########################################################################
+# Dependencies generated by make depend
+# DO NOT DELETE THIS LINE -- make depend relies on it
+
+# Put nothing here or make depend will gobble it up
+.FORCE_DEPEND::
+ @echo "You must run 'make depend' in $(TOP) first."; exit 1
!NO!SUBS!
chmod 644 Makefile
$eunicefix Makefile
diff --git a/bin/manilist.SH b/bin/manilist.SH
index 8bfb341..42972ef 100755
--- a/bin/manilist.SH
+++ b/bin/manilist.SH
@@ -17,10 +17,10 @@ esac
echo "Extracting bin/manilist (with variable substitutions)"
$spitshell >manilist <<!GROK!THIS!
$startperl
- eval 'exec perl -S \$0 "\$@"'
+ eval 'exec perl -S \$0 \${1+"\$@"}'
if \$running_under_some_shell;
-# $Id: manilist.SH 20 2008-01-04 23:14:00Z rmanfredi $
+# $Id: manilist.SH 31 2010-03-06 20:15:24Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
diff --git a/bin/packinit.SH b/bin/packinit.SH
index 478839d..d0e6d9f 100755
--- a/bin/packinit.SH
+++ b/bin/packinit.SH
@@ -17,10 +17,10 @@ esac
echo "Extracting bin/packinit (with variable substitutions)"
cat >packinit <<!GROK!THIS!
# feed this into perl
- eval "exec perl -S \$0 \$*"
+ eval 'exec perl -S \$0 \${1+"\$@"}'
if \$running_under_some_shell;
-# $Id: packinit.SH 1 2006-08-24 12:32:52Z rmanfredi $
+# $Id: packinit.SH 31 2010-03-06 20:15:24Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
diff --git a/bin/perload b/bin/perload
index a0ed31c..4dc77c2 100755
--- a/bin/perload
+++ b/bin/perload
@@ -37,8 +37,8 @@ $current_package = 'main'; # Current package
$init_emitted = 0; # True when dataloading stamp was emitted
$in_function = 0;
-require 'getopt.pl';
-&Getopt;
+use Getopt::Std;
+getopts("ot");
while (<>) {
if ($. == 1 && /^(:|#).*perl/) { # Invocation stub
diff --git a/bin/svn-revision b/bin/svn-revision
index 0d88b3b..c698135 100755
--- a/bin/svn-revision
+++ b/bin/svn-revision
@@ -25,7 +25,7 @@ if [ "x$FILE" = x ]; then
FILE="&1"
oldrev=''
else
- oldrev=`grep REVISION "$FILE" 2>/dev/null | head -n1 | cut -d' ' -f3`
+ oldrev=`grep REVISION "$FILE" 2>/dev/null | head -n1 | cut -d' ' -f4`
fi
if test -d "$TOP/.svn"; then
@@ -52,8 +52,9 @@ EOF
if [ "x$revnum" = x ]; then
echo '/* Subversion information not available */'
else
+ XRev='$Revision'
cat <<EOF
-#define REVISION $revnum
+#define REVISION "$XRev: $revnum \$"
EOF
fi