summaryrefslogtreecommitdiff
path: root/debian/dist.config
diff options
context:
space:
mode:
authorBoyuan Yang <byang@debian.org>2020-02-23 14:37:44 -0800
committerBoyuan Yang <byang@debian.org>2020-02-23 14:37:44 -0800
commitad837af33e152566dc47d6805cb0a84ce1329ed5 (patch)
tree15fc67268928e2784b815b959de3f9e6212686ef /debian/dist.config
parentceb3507a8fca872770b3dcd7e5c5b36179ab95b0 (diff)
dist (1:3.5-236-0.2) unstable; urgency=medium
* Non-maintainer upload. * debian/dist.postinst: Fix wrong direction form. (Closes: #908187) * debian/rules: Explicitly provide tool path to avoid usrmerge differences and make package reproducible. (Closes: #915910) * debian/rules: Avoid manually setting DEB_HOST_MULTIARCH, use /usr/share/dpkg/architecture.mk instead. (lintian warning) [dgit import package dist 1:3.5-236-0.2]
Diffstat (limited to 'debian/dist.config')
-rw-r--r--debian/dist.config82
1 files changed, 82 insertions, 0 deletions
diff --git a/debian/dist.config b/debian/dist.config
new file mode 100644
index 0000000..92b72b1
--- /dev/null
+++ b/debian/dist.config
@@ -0,0 +1,82 @@
+#!/bin/sh
+# -*- Mode: Sh -*-
+# config ---
+# Author : Manoj Srivastava ( srivasta@glaurung.green-gryphon.com )
+# Created On : Fri Oct 31 21:53:31 2003
+# Created On Node : glaurung.green-gryphon.com
+# Last Modified By : Manoj Srivastava
+# Last Modified On : Tue Dec 2 21:36:50 2003
+# Last Machine Used: glaurung.green-gryphon.com
+# Update Count : 13
+# Status : Unknown, Use with caution!
+# HISTORY :
+# Description :
+# arch-tag: 1c40a2eb-f28c-41b5-a423-671be2e816ed
+#
+
+set -e
+
+case "$1" in
+ configure)
+ # Configure this package. If the package must prompt the user for
+ # information, do it here.
+ if [ ! -e /etc/news/organization ]; then
+ if [ -e /usr/share/debconf/confmodule ]; then
+ . /usr/share/debconf/confmodule
+ db_capb
+ ok=''
+ # See if the old shared question still exists.
+ if db_get share/news/organization; then
+ if [ "X$RET" != "X" ]; then
+ ok=1
+ break
+ fi
+ fi
+ while [ ! "$ok" ]; do
+ retval=$(db_input low shared/news/organization) || true
+ if [ "$retval" = "30 question skipped" ]; then
+ ok=1
+ fi
+ db_go || true
+ db_get shared/news/organization
+ if [ "X$RET" != "X" ]; then
+ ok=1
+ break
+ fi
+ done
+ fi
+ fi
+
+ ;;
+ reconfigure)
+ if [ ! -e /etc/news/organization ]; then
+ if [ -e /usr/share/debconf/confmodule ]; then
+ . /usr/share/debconf/confmodule
+ db_capb
+ ok=''
+ # See if the old shared question still exists.
+ if db_get share/news/organization; then
+ if [ "X$RET" != "X" ]; then
+ ok=1
+ break
+ fi
+ fi
+ while [ ! "$ok" ]; do
+ retval=$(db_input low shared/news/organization) || true
+ if [ "$retval" = "30 question skipped" ]; then
+ ok=1
+ fi
+ db_go || true
+ db_get shared/news/organization
+ if [ "X$RET" != "X" ]; then
+ ok=1
+ break
+ fi
+ done
+ fi
+ fi
+ ;;
+ *) echo "$0: didn't understand being called with \`$1'" 1>&2
+ exit 0;;
+esac
+