summaryrefslogtreecommitdiff
path: root/jmake/Makefile.SH
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@golden-gryphon.com>2014-04-27 17:54:01 -0700
committerManoj Srivastava <srivasta@golden-gryphon.com>2014-04-27 17:54:01 -0700
commit8f5e5726134ce5b4bd436b16f367796d851df553 (patch)
tree0ce2ad130721dcf917d7f81fb8495bf0a189d266 /jmake/Makefile.SH
parent02bf7be6fc0f798790ef5b2160bc89a77b909428 (diff)
Imported Upstream version 3.5-36
Diffstat (limited to 'jmake/Makefile.SH')
-rwxr-xr-xjmake/Makefile.SH26
1 files changed, 20 insertions, 6 deletions
diff --git a/jmake/Makefile.SH b/jmake/Makefile.SH
index 6a651e3..76a7182 100755
--- a/jmake/Makefile.SH
+++ b/jmake/Makefile.SH
@@ -1,5 +1,5 @@
-: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5 PL0]
-: $X-Id: Jmake.tmpl 8 2006-08-25 22:27:18Z rmanfredi $
+: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5-172]
+: $X-Id: Jmake.tmpl 156 2012-12-19 16:44:39Z rmanfredi $
case $CONFIG in
'')
@@ -59,12 +59,12 @@ SCRIPTS = jmake jmkmf
$spitshell >>Makefile <<'!NO!SUBS!'
########################################################################
# Jmake rules for building libraries, programs, scripts, and data files
-# $X-Id: Jmake.rules 8 2006-08-25 22:27:18Z rmanfredi $
+# $X-Id: Jmake.rules 106 2011-11-25 20:36:12Z rmanfredi $
########################################################################
# Start of Jmakefile
-# $X-Id: Jmakefile 3 2006-08-25 21:39:07Z rmanfredi $
+# $X-Id: Jmakefile 173 2014-04-05 08:10:18Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
@@ -90,7 +90,7 @@ all:: Index
local_realclean::
$(RM) Index
-Index: bindex
+Index: bindex files/Jmake.rules
chmod +x bindex
./bindex
@@ -210,7 +210,8 @@ local_deinstall::
BINSH = jmake.SH fixcpp.SH
-depend::
+depend:: local_depend
+local_depend::
($(SED) '/^# DO NOT DELETE/q' Makefile && \
grep '^\$$grep' $(BINSH) | \
$(SED) -e "s/^.*' \([^ ]*\) >>\([^ ]*\)/\2: \1/" \
@@ -219,6 +220,8 @@ depend::
cp Makefile.new Makefile
$(RM) Makefile.new
+fixcpp jmake: $(TOP)/revision.h
+
########################################################################
# Common rules for all Makefiles -- do not edit
@@ -238,6 +241,8 @@ local_clobber:: local_realclean
$(RM) Makefile config.sh
install:: local_install
+ @exit 0
+
install.man:: maybe_install.man
deinstall:: local_deinstall
deinstall.man:: maybe_deinstall.man
@@ -278,6 +283,8 @@ tags::
local_clobber::
$(RM) tags
+depend::
+
########################################################################
# Empty rules for directories with no sub-directories -- do not edit
@@ -297,6 +304,13 @@ Makefiles::
Makefiles.SH::
+########################################################################
+# Dependencies generated by make depend
+# DO NOT DELETE THIS LINE -- make depend relies on it
+
+# Put nothing here or make depend will gobble it up
+.FORCE_DEPEND::
+ @echo "You must run 'make depend' in $(TOP) first."; exit 1
!NO!SUBS!
chmod 644 Makefile
$eunicefix Makefile