summaryrefslogtreecommitdiff
path: root/mcon/Makefile.SH
diff options
context:
space:
mode:
authorrmanfredi <rmanfredi@2592e710-e01b-42a5-8df0-11608a6cc53d>2010-11-28 23:05:09 +0000
committerrmanfredi <rmanfredi@2592e710-e01b-42a5-8df0-11608a6cc53d>2010-11-28 23:05:09 +0000
commit36a47742bb84eb86d0a1095bbbefd6e905f39d4f (patch)
tree21e21ebb1aee2bbf99a0a048e370fedfd7d92884 /mcon/Makefile.SH
parent17a95c14fc05fe53f250d627b55ea588321c7129 (diff)
Added the notion of local_depend and sub_depend.
This allows one to do a "make local_depend" after Makefile.SH extraction without having to recurse to subdirs. git-svn-id: svn://svn.code.sf.net/p/dist/code/trunk/dist@48 2592e710-e01b-42a5-8df0-11608a6cc53d
Diffstat (limited to 'mcon/Makefile.SH')
-rwxr-xr-xmcon/Makefile.SH7
1 files changed, 5 insertions, 2 deletions
diff --git a/mcon/Makefile.SH b/mcon/Makefile.SH
index dece2f3..9024ec1 100755
--- a/mcon/Makefile.SH
+++ b/mcon/Makefile.SH
@@ -1,5 +1,5 @@
: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5-43]
-: $X-Id: Jmake.tmpl 30 2009-10-28 07:45:28Z rmanfredi $
+: $X-Id: Jmake.tmpl 47 2010-11-28 22:23:13Z rmanfredi $
case $CONFIG in
'')
@@ -266,7 +266,8 @@ BINSH = \
mlint.SH \
mxref.SH
-depend::
+depend:: local_depend
+local_depend::
($(SED) '/^# DO NOT DELETE/q' Makefile && \
grep '^\$$grep' $(BINSH) | \
$(SED) -e "s/^.*' \([^ ]*\) >>\([^ ]*\)/\2: \1/" \
@@ -326,6 +327,8 @@ tags::
local_clobber::
$(RM) tags
+depend::
+
########################################################################
# Rules for building in sub-directories -- do not edit