summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog34
-rw-r--r--debian/compat1
-rw-r--r--debian/control15
-rw-r--r--debian/copyright4
-rw-r--r--debian/dist.postinst4
-rwxr-xr-xdebian/rules15
6 files changed, 54 insertions, 19 deletions
diff --git a/debian/changelog b/debian/changelog
index af024fa..c394f08 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,39 @@
+dist (1:3.5-236-1) unstable; urgency=medium
+
+ * New upstream git snapshot
+ * Ack NMUs
+ * Update VCS-* headers in control
+ * Move to standards version 4.3.0 (no changes were needed).
+
+ -- Manoj Srivastava <srivasta@debian.org> Tue, 19 May 2020 20:46:55 -0700
+
+dist (1:3.5-236-0.2) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * debian/dist.postinst: Fix wrong direction form.
+ (Closes: #908187)
+ * debian/rules: Explicitly provide tool path to avoid usrmerge
+ differences and make package reproducible. (Closes: #915910)
+ * debian/rules: Avoid manually setting DEB_HOST_MULTIARCH, use
+ /usr/share/dpkg/architecture.mk instead. (lintian warning)
+
+ -- Boyuan Yang <byang@debian.org> Sun, 23 Feb 2020 17:37:44 -0500
+
+dist (1:3.5-236-0.1) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * New upstream snapshot (Closes: #898955)
+ * Fix some syntax errors in various scripts (Closes: #899207)
+ * Restore missing dependency libperl4-corelibs-perl
+ * Fix Lintian error by removing Build-Depends-Indep: dpkg-dev
+
+ -- Dominic Hargreaves <dom@earth.li> Sun, 20 May 2018 22:35:58 +0200
+
dist (1:3.5-36.0001-3) unstable; urgency=medium
[ Helmut Grohne ]
* Mark dist Multi-Arch: foreign.
-
- [ Manoj Srivastava ]
+ [ Manoj Srivastava ]
* Update the copyright file
* Incorporated Helmut's chqange, which, unless I missed it, newver made
it out.
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index ec63514..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/debian/control b/debian/control
index 9acc616..bdfb310 100644
--- a/debian/control
+++ b/debian/control
@@ -1,19 +1,18 @@
Source: dist
-VCS-Git: https://anonscm.debian.org/git/users/srivasta/debian/dist.git
-VCS-Browser: http://anonscm.debian.org/gitweb/?p=users/srivasta/debian/dist.git
+VCS-Git: https://salsa.debian.org/srivasta/dist.git
+VCS-Browser: https://salsa.debian.org/srivasta/dist
Section: devel
Priority: optional
Maintainer: Manoj Srivastava <srivasta@debian.org>
-Standards-Version: 4.1.3
-Build-Depends-Indep: debhelper (>= 11), sharutils, po-debconf,
- gettext, dpkg-dev (>= 1.16.0),
- libperl4-corelibs-perl | perl (<< 5.12.3-7)
+Standards-Version: 4.3.0
+Build-Depends: debhelper-compat (=12)
+Build-Depends-Indep: sharutils, po-debconf, gettext
Package: dist
Architecture: all
Multi-Arch: foreign
-Depends: perl, debconf (>= 1.2.0) | debconf-2.0,
- ${misc:Depends}, libperl4-corelibs-perl | perl (<< 5.12.3-7)
+Depends: perl, libperl4-corelibs-perl, debconf (>= 1.2.0) | debconf-2.0,
+ ${misc:Depends}
Description: Tools for developing, maintaining and distributing software
The dist package is a set of tools meant to ease the construction
and maintenance of portable software.
diff --git a/debian/copyright b/debian/copyright
index 8500bf1..1108b31 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,4 +1,4 @@
-Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: dist 3.0
Upstream-Contact: Raphael Manfredi <Raphael_Manfredi@grenoble.hp.com>
Sources: https://svn.code.sf.net/p/dist/code/trunk/dist
@@ -91,7 +91,7 @@ License: GPL-2+
GNU General Public License for more details.
.
You should have received a copy of the GNU General Public License
- along with this program. If not, see <http://www.gnu.org/licenses/>.
+ along with this program. If not, see <https://www.gnu.org/licenses/>.
.
On Debian systems, the complete text of the GNU General
Public License can be found in "/usr/share/common-licenses/GPL-2".
diff --git a/debian/dist.postinst b/debian/dist.postinst
index 7043cce..3e8da16 100644
--- a/debian/dist.postinst
+++ b/debian/dist.postinst
@@ -288,7 +288,7 @@ EOH
set_org_perms () {
chown root /etc/news/organization
- if grep news /etc/group 2>&1 >/dev/null ; then
+ if grep news /etc/group > /dev/null 2>&1 ; then
chgrp news /etc/news/organization
else
chgrp root /etc/news/organization
@@ -397,7 +397,7 @@ case "$1" in
if test ! -d /etc/news ; then
mkdir /etc/news
chown root /etc/news
- if grep news /etc/group 2>&1 >/dev/null ; then
+ if grep news /etc/group > /dev/null 2>&1 ; then
chgrp news /etc/news
else
echo "darn, you do not have news in /etc/group"
diff --git a/debian/rules b/debian/rules
index a70d8c6..a4abf3d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,8 +23,8 @@ PAT_EXEC = patcil patdiff patbase patlog patmake patsend \
patnotify patpost patftp patname patsnap patcol \
patclean patindex
-DPKG_ARCH := dpkg-architecture
-export DEB_HOST_MULTIARCH := $(shell $(DPKG_ARCH) $(ha) -qDEB_HOST_MULTIARCH)
+# For DEB_HOST_MULTIARCH
+include /usr/share/dpkg/architecture.mk
%:
dh $@
@@ -35,15 +35,19 @@ override_dh_auto_configure:
touch .config/nomail && \
sh ./Configure \
-de \
- -D prefix=$(PREFIX) \
+ -D prefix=/usr \
-D orgname=/etc/news/organization \
-D myhostname=localhost \
-D mydomain=localdomain \
-D defeditor=/usr/ae \
- -D privlib=/usr/share/$(package) \
+ -D privlib=/usr/share/$(package) \
-D pager=/bin/more \
-D mansrc=/usr/share/man/ \
-D cf_email='$(email)' \
+ -D grep=/bin/grep \
+ -D sed=/bin/sed \
+ -D cat=/bin/cat \
+ -D zcat=/bin/zcat \
-D d_berknames='define'
@@ -57,6 +61,9 @@ override_dh_auto_build:
override_dh_install:
test -d $(MAN1DIR) || $(make_directory) $(MAN1DIR)
$(MAKE) install
+ for script in $(TMPTOP)/usr/bin/*; do \
+ test `head -1 $$script` = '#!/usr/bin/perl' && perl -c $$script ;\
+ done
$(MAKE) install.man
$(make_directory) $(MAN7DIR)
(cd $(MAN1DIR); for file in $(PAT_EXEC) ; do \