summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas De Loof <nicolas.deloof@gmail.com>2019-12-03 11:44:30 +0100
committerNicolas De loof <nicolas.deloof@gmail.com>2020-01-08 10:15:48 +0100
commitc5c287db5c31c2107bfd5778205e54fe9bf30b84 (patch)
tree956a4efc4060300b9b78501cbc9a67c6d81f67b4
parentdd889b990b723edf08c21b7442d02f603cf8eec1 (diff)
We don't use FOSSA anymore
Signed-off-by: Nicolas De Loof <nicolas.deloof@gmail.com>
-rw-r--r--script/Jenkinsfile.fossa20
-rw-r--r--script/fossa.mk16
2 files changed, 0 insertions, 36 deletions
diff --git a/script/Jenkinsfile.fossa b/script/Jenkinsfile.fossa
deleted file mode 100644
index 480e98ef..00000000
--- a/script/Jenkinsfile.fossa
+++ /dev/null
@@ -1,20 +0,0 @@
-pipeline {
- agent any
- stages {
- stage("License Scan") {
- agent {
- label 'ubuntu-1604-aufs-edge'
- }
-
- steps {
- withCredentials([
- string(credentialsId: 'fossa-api-key', variable: 'FOSSA_API_KEY')
- ]) {
- checkout scm
- sh "FOSSA_API_KEY='${FOSSA_API_KEY}' BRANCH_NAME='${env.BRANCH_NAME}' make -f script/fossa.mk fossa-analyze"
- sh "FOSSA_API_KEY='${FOSSA_API_KEY}' make -f script/fossa.mk fossa-test"
- }
- }
- }
- }
-}
diff --git a/script/fossa.mk b/script/fossa.mk
deleted file mode 100644
index 8d7af49d..00000000
--- a/script/fossa.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-# Variables for Fossa
-BUILD_ANALYZER?=docker/fossa-analyzer
-FOSSA_OPTS?=--option all-tags:true --option allow-unresolved:true
-
-fossa-analyze:
- docker run --rm -e FOSSA_API_KEY=$(FOSSA_API_KEY) \
- -v $(CURDIR)/$*:/go/src/github.com/docker/compose \
- -w /go/src/github.com/docker/compose \
- $(BUILD_ANALYZER) analyze ${FOSSA_OPTS} --branch ${BRANCH_NAME}
-
- # This command is used to run the fossa test command
-fossa-test:
- docker run -i -e FOSSA_API_KEY=$(FOSSA_API_KEY) \
- -v $(CURDIR)/$*:/go/src/github.com/docker/compose \
- -w /go/src/github.com/docker/compose \
- $(BUILD_ANALYZER) test