summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDjordje Lukic <djordje.lukic@docker.com>2019-10-28 11:33:59 +0100
committerDjordje Lukic <djordje.lukic@docker.com>2019-10-28 11:33:59 +0100
commitc7e82489f4bf8ebef4afc22848d121b39aa2e769 (patch)
tree969654492a8d4fb88ac55edc295491dd52b891a2
parent952340043a0012be41e331a47321232a7a475136 (diff)
"Bump 1.25.0-rc3"
Signed-off-by: Djordje Lukic <djordje.lukic@docker.com>
-rw-r--r--CHANGELOG.md83
-rw-r--r--compose/__init__.py2
-rwxr-xr-xscript/run/run.sh2
3 files changed, 85 insertions, 2 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 7a3ad8bf..210aecd4 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,89 @@
Change log
==========
+1.25.0-rc3 (2019-10-28)
+-------------------
+
+### Features
+
+- Add BuildKit support, use `DOCKER_BUILDKIT=1` and `COMPOSE_NATIVE_BUILDER=1`
+
+- Bump paramiko to 2.6.0
+
+- Add working dir, config files and env file in service labels
+
+- Add tag `docker-compose:latest`
+
+- Add `docker-compose:<version>-alpine` image/tag
+
+- Add `docker-compose:<version>-debian` image/tag
+
+- Bumped `docker-py` 4.1.0
+
+- Supports `requests` up to 2.22.0 version
+
+- Drops empty tag on `build:cache_from`
+
+- `Dockerfile` now generates `libmusl` binaries for alpine
+
+- Only pull images that can't be built
+
+- Attribute `scale` can now accept `0` as a value
+
+- Added `--quiet` build flag
+
+- Added `--no-interpolate` to `docker-compose config`
+
+- Bump OpenSSL for macOS build (`1.1.0j` to `1.1.1c`)
+
+- Added `--no-rm` to `build` command
+
+- Added support for `credential_spec`
+
+- Resolve digests without pulling image
+
+- Upgrade `pyyaml` to `4.2b1`
+
+- Lowered severity to `warning` if `down` tries to remove nonexisting image
+
+- Use improved API fields for project events when possible
+
+- Update `setup.py` for modern `pypi/setuptools` and remove `pandoc` dependencies
+
+- Removed `Dockerfile.armhf` which is no longer needed
+
+### Bugfixes
+
+- Fix same file 'extends' optimization
+
+- Use python POSIX support to get tty size
+
+- Format image size as decimal to be align with Docker CLI
+
+- Fixed stdin_open
+
+- Fixed `--remove-orphans` when used with `up --no-start`
+
+- Fixed `docker-compose ps --all`
+
+- Fixed `depends_on` dependency recreation behavior
+
+- Fixed bash completion for `build --memory`
+
+- Fixed misleading warning concerning env vars when performing an `exec` command
+
+- Fixed failure check in parallel_execute_watch
+
+- Fixed race condition after pulling image
+
+- Fixed error on duplicate mount points.
+
+- Fixed merge on networks section
+
+- Always connect Compose container to `stdin`
+
+- Fixed the presentation of failed services on 'docker-compose start' when containers are not available
+
1.24.0 (2019-03-28)
-------------------
diff --git a/compose/__init__.py b/compose/__init__.py
index 0042896b..552f91b2 100644
--- a/compose/__init__.py
+++ b/compose/__init__.py
@@ -1,4 +1,4 @@
from __future__ import absolute_import
from __future__ import unicode_literals
-__version__ = '1.25.0dev'
+__version__ = '1.25.0-rc3'
diff --git a/script/run/run.sh b/script/run/run.sh
index f3456720..f7d6eb35 100755
--- a/script/run/run.sh
+++ b/script/run/run.sh
@@ -15,7 +15,7 @@
set -e
-VERSION="1.24.0"
+VERSION="1.25.0-rc3"
IMAGE="docker/compose:$VERSION"