summaryrefslogtreecommitdiff
path: root/debian/control
diff options
context:
space:
mode:
authorFelipe Sateler <fsateler@debian.org>2018-10-02 16:48:52 -0300
committerFelipe Sateler <fsateler@debian.org>2018-10-02 16:48:52 -0300
commit9fc5803e6651c0b8e5be05136c34c1236a26637b (patch)
tree1393f44139844692b2b9e706c37bbea27338db2e /debian/control
parent9b42a95a364fe491ab27b4730579c1bb222f0829 (diff)
Switch to using python3 instead of python2
Also removes the need for the ssl-match-hostname backport. Closes: #909974
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control32
1 files changed, 16 insertions, 16 deletions
diff --git a/debian/control b/debian/control
index cb9dae3f..3b907109 100644
--- a/debian/control
+++ b/debian/control
@@ -6,30 +6,30 @@ Section: admin
Priority: optional
Build-Depends:
debhelper (>= 10),
- python (>= 2.6.6-3),
+ python3 (>= 3.6),
dh-python,
- python-cached-property (>= 1.2.0),
- python-setuptools (>= 0.6b3),
- python-docker (>= 3.2.1),
- python-dockerpty (>= 0.4.1),
- python-docopt (>= 0.6.1),
- python-yaml (>= 3.10),
- python-requests (>= 2.6.1),
- python-six (>= 1.7.3),
- python-texttable (>= 0.9.0),
- python-websocket (>= 0.32.0),
- python-mock (>= 1.0.1),
- python-nose,
- python-flake8,
+ python3-cached-property (>= 1.2.0),
+ python3-setuptools (>= 0.6b3),
+ python3-docker (>= 3.2.1),
+ python3-dockerpty (>= 0.4.1),
+ python3-docopt (>= 0.6.1),
+ python3-yaml (>= 3.10),
+ python3-requests (>= 2.6.1),
+ python3-six (>= 1.7.3),
+ python3-texttable (>= 0.9.0),
+ python3-websocket (>= 0.32.0),
+ python3-mock (>= 1.0.1),
+ python3-nose,
+ python3-flake8,
Standards-Version: 4.1.4
-X-Python-Version: >= 2.5
+X-Python3-Version: >= 3.6
Homepage: http://docs.docker.com/compose/
Vcs-Git: https://salsa.debian.org/docker-compose-team/docker-compose
Vcs-Browser: https://salsa.debian.org/docker-compose-team/docker-compose
Package: docker-compose
Architecture: all
-Depends: ${misc:Depends}, ${python:Depends}
+Depends: ${misc:Depends}, ${python3:Depends}
Recommends: docker.io (>= 1.9.0)
Description: Punctual, lightweight development environments using Docker
docker-compose is a service management software built on top of docker. Define